Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » External Tools Input(The input will not work with an external tool)
External Tools Input [message #1058914] Wed, 15 May 2013 14:01 Go to next message
Blaine Goscha is currently offline Blaine Goscha
Messages: 3
Registered: February 2013
Junior Member
I am trying to run a command using an external tool but the input is not working correctly. The command prompts the user for info and it works on the command line, but when I run the same command on the same file using an external tool it will not accept the users input. Is there a way to fix this? Thanks.
Re: External Tools Input [message #1059268 is a reply to message #1058914] Thu, 16 May 2013 01:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26014
Registered: July 2009
Senior Member
Blaine,

Does your launcher configuration for this tool specify to allocate a
console (on the Common tab)?


On 15/05/2013 8:01 PM, Blaine Goscha wrote:
> I am trying to run a command using an external tool but the input is
> not working correctly. The command prompts the user for info and it
> works on the command line, but when I run the same command on the same
> file using an external tool it will not accept the users input. Is
> there a way to fix this? Thanks.
Re: External Tools Input [message #1060023 is a reply to message #1059268] Wed, 22 May 2013 10:54 Go to previous messageGo to next message
Blaine Goscha is currently offline Blaine Goscha
Messages: 3
Registered: February 2013
Junior Member
Yeah, I made sure to do that. The command prints some output to the console but will not take any input.
Re: External Tools Input [message #1060051 is a reply to message #1060023] Wed, 22 May 2013 13:08 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26014
Registered: July 2009
Senior Member
Blaine,

Strange. I have no idea...


On 22/05/2013 4:54 PM, Blaine Goscha wrote:
> Yeah, I made sure to do that. The command prints some output to the
> console but will not take any input.
Previous Topic:OSGi Application name is null in VisualVM
Next Topic:Can't Access Eclipse Error Message
Goto Forum:
  


Current Time: Tue Sep 02 02:54:35 EDT 2014

Powered by FUDForum. Page generated in 0.01797 seconds