Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » error loading module 'stagedb.core'(Seek help)
error loading module 'stagedb.core' [message #1058435] Tue, 14 May 2013 06:09 Go to next message
农夫 曾 is currently offline 农夫 曾Friend
Messages: 1
Registered: May 2013
Junior Member
2013-05-14 05:40:15 GENERAL-INFO: ************************************************************
2013-05-14 05:40:15 GENERAL-INFO: Starting Agent ...
2013-05-14 05:40:15 GENERAL-INFO: Agent: 0.9-DEV
2013-05-14 05:40:15 GENERAL-INFO: Lua VM: Lua 5.1.4 (+meta pairs/ipairs) (+patch-lua-5.1.4-3)
2013-05-14 05:40:15 GENERAL-INFO: System: Linux WNDR3700v4 2.6.31 #6 Tue May 14 13:24:41 CST 2013 mips
2013-05-14 05:40:15 GENERAL-INFO: ************************************************************
2013-05-14 05:40:15 GENERAL-INFO: Device ID = "012345678901234"
2013-05-14 05:40:15 GENERAL-INFO: Module [AssetConnector] initialized
2013-05-14 05:40:15 SHELL-INFO: Binding a shell server at address ?localhost, port 2000
2013-05-14 05:40:15 GENERAL-INFO: Module [Lua Shell] initialized
2013-05-14 05:40:15 GENERAL-INFO: Module [DummyNetman] initialized
2013-05-14 05:40:15 GENERAL-INFO: Module [Lua RPC] initialized
2013-05-14 05:40:15 GENERAL-INFO: Module [ServerConnector] initialized
2013-05-14 05:40:15 GENERAL-ERROR: Failed to initialize module [DataManagement], err=error loading module 'stagedb.core' from file 'lua/stagedb.so':
File not found
2013-05-14 05:40:15 ASSCON-INFO: Connection received from asset [table: 0x4b0730] at '<local ipc=table: 0x4b9eb0>:0'
2013-05-14 05:40:15 ASSCON-INFO: Asset registered, name="@sys", id=table: 0x4b0730.
2013-05-14 05:40:15 GENERAL-INFO: Module [DeviceManagement] initialized



Ported to the MIPS platform router performs error!!
Re: error loading module 'stagedb.core' [message #1058544 is a reply to message #1058435] Tue, 14 May 2013 12:37 Go to previous messageGo to next message
Benjamin Cabé is currently offline Benjamin CabéFriend
Messages: 156
Registered: July 2009
Location: Toulouse, France
Senior Member

Hi 农夫 曾!
It looks like a problem in your cross compilation, I think I've seen this error before. I am assuming you are trying to compile against an OpenWRT toolchain?
I suggest that you report your problem on the Mihini mailing list: https://dev.eclipse.org/mailman/listinfo/mihini-dev and maybe you could add some details on your compilation environment

Hope this helps!
Benjamin.
Re: error loading module 'stagedb.core' [message #1059195 is a reply to message #1058544] Fri, 17 May 2013 08:32 Go to previous message
Benjamin Cabé is currently offline Benjamin CabéFriend
Messages: 156
Registered: July 2009
Location: Toulouse, France
Senior Member

Hi 农夫 曾!
I don't think I've seen you posting on mihini-dev mailing list. Have you been able to solve your issue?

Benjamin.
Previous Topic:Better LuaJIT FFI support
Next Topic:Debugging with Corona SDK (Juno)
Goto Forum:
  


Current Time: Thu Dec 18 11:40:10 GMT 2014

Powered by FUDForum. Page generated in 0.02094 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software