Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » How to "run" a PHP file
How to "run" a PHP file [message #1058399] Mon, 13 May 2013 23:09 Go to next message
Lucas Malor
Messages: 12
Registered: May 2013
Junior Member
EDIT: ignore the following and read comment #3

-------------------------------------------------------------------------

Hi all. I'm a total newbie and I'm trying to develop a simple site. I installed PHPEclipse and I would be able to open the current php script inside my browser. I think I can do this some way, since I have the possibility to specify the browser in PHPEclipse settings.

Furthermore, I find the code templates a little buggy, as I explained here:
stackoverflow.com/questions/16528675/phpeclipse-code-templates-incorrect-indenting

Unfortunately it seems I can't open a new ticket on PHPEclipse site.

(Out for curiosity... why is there no PHPEclipse subforum?)

[Updated on: Wed, 05 June 2013 08:03]

Report message to a moderator

Re: How to "run" with PHPEclipse, and a bug [message #1058436 is a reply to message #1058399] Tue, 14 May 2013 06:09 Go to previous messageGo to next message
john cruz is currently offline john cruz
Messages: 2
Registered: May 2013
Junior Member
You just need to edit the server configuration in Eclipse in order to run with PHPEclipse.
Re: How to "run" with PHPEclipse, and a bug [message #1061549 is a reply to message #1058436] Sun, 02 June 2013 18:06 Go to previous messageGo to next message
Lucas Malor
Messages: 12
Registered: May 2013
Junior Member
Since PHPEclipse has too much bugs, I switched to PDT. Anyway I have problems running PHP files. The opened url is "localhost/PROJECT/FILE" instead of "localhost/workspace/PROJECT/FILE"

I have installed XAMPP for Linux and I created a soft link to the workspace folder. So http:/ /locahost/workspace/ points to ~/workspace/.

I have modified the Eclipse settings, going to PHP -> PHP Server, selected the default server, edited it and wrote ~/workspace to local web root. I tried to insert localhost/workspace, but I can insert the domain name only. I also tried to add localhost/workspace/ as "Path on Server" and "~/workspace" as "Path in File System", but nothing.

[Updated on: Sun, 02 June 2013 18:12]

Report message to a moderator

Re: How to "run" with PHPEclipse, and a bug [message #1061831 is a reply to message #1061549] Tue, 04 June 2013 09:59 Go to previous message
Lucas Malor
Messages: 12
Registered: May 2013
Junior Member
Ok, strangely now it works and I've not changed nothing... the problem is that every time that I open an URL inside localhost Eclipse starts a step-by-step debug session. I had to remove all the server configurations to disable it.

Is there a way to simply open the file with the external browser without debugging?
Previous Topic:how to get the actual expression from AST
Next Topic:If you copy & paste code, indentation is messed up
Goto Forum:
  


Current Time: Fri Sep 19 21:55:54 GMT 2014

Powered by FUDForum. Page generated in 0.01618 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software