Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Object Mapping Mode always disabled
Object Mapping Mode always disabled [message #1058396] Mon, 13 May 2013 18:05 Go to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
I'm running Jubula 2.0.00148

Under what conditions does the Object Mapping Mode icon get enabled? Right now my icon is always disabled.

From the Linux Redhat 6.2 Desktop I've started the AUT Agent, and then I start Jubula. Within Jubula I've successfully connected to the AUT Agent [locahost@60000] and then started the AUT (which has the rcp-support.zip installed and verified in it: Help > About > Installation Details showing 5 org.eclipse.jubula.rc.rcp* plugins). But the Object Mapping Mode icon stays disabled.

Would you have any pointers to troubleshooting or thoughts of things I could try to resolve what is broken?

Is there a "hello-world" test application zip with the rcp-support preinstalled in it correctly that I could use to insure I've got things configured right?

Thanks.

[Updated on: Wed, 15 May 2013 12:35]

Report message to a moderator

Re: Object Mapping Mode always disabled [message #1058397 is a reply to message #1058396] Mon, 13 May 2013 18:09 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
Some more information...

The "Starting AUT with ID: <X>" shows in the Progress tab forever, that is, it never completes, and the RCP application starts on the remote system and its main window appears. However, nothing gets listed in the "Running AUTs" tab.

[Updated on: Wed, 15 May 2013 12:51]

Report message to a moderator

Re: Object Mapping Mode always disabled [message #1058505 is a reply to message #1058397] Tue, 14 May 2013 07:29 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1055
Registered: July 2009
Senior Member
Hi,

Thanks for the information - especially the second part! If the AUT isn't listed, that means it's not started "correctly". That's the reason for the disabled OMM button.

As to why it's not starting correctly - a few thoughts:

- What Eclipse version are you using?
- Can you find out if your AUT allows bundles to be added in the way the RCP accessor is added? Some AUTs may need the RCP files added in a different way, as documented in the user manual.
- You said the main window, but I'm going to ask anyway Smile : does the AUT have a splash screen? If so, then you should configure the workspace path in the AUT Configuration
- One other troubleshooting option is to start the AUT using "autrun" (docu here). It doesn't work any differently necessarily, but it does give you the command line output Smile
- One last question - were you using Jubula before this (i.e. did it previously work, or have you just begun).

Thanks for the additional info!
Alex
Re: Object Mapping Mode always disabled [message #1058588 is a reply to message #1058505] Tue, 14 May 2013 10:04 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
- What Eclipse version are you using? I am testing Eclipse for Parallel Applications latest build on Kepler 4.3 M7. In other words my AUT is Eclipse itself.
- AUT bundle addition? I installed rcp-support.zip by unzipping it into the plugins directory and editing config.ini to add in the bundle name. Is there some other way? I do see the org.eclipse.jubula.rc.rcp plugin in installed plugins
- Does AUT have splash screen? It's Eclipse, and it definitely has a splash screen.
- Use autrun. I will try autrun when I get to the office shortly
- Have you just begun? Over the past year I have tried Jubula on two previous occasions to understand what it provides. Both were following the online tutorial. The first was unsuccessful and the second last December was successful but Jubula did not support Eclipse 4. Now with Jubula 2.0 however I am pursuing using Jubula in earnest with some testing of our team's development. Since we do very little automated GUI testing of Eclipse for Parallel Application I am using my work to help decide if we will pursue using it. In summary, treat me as a total newcomer
Re: Object Mapping Mode always disabled [message #1058595 is a reply to message #1058588] Tue, 14 May 2013 10:12 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
A question, does standalone Jubula need to run on a specific Java JVM, for example, a specific vendor, version, or address range?
Re: Object Mapping Mode always disabled [message #1058753 is a reply to message #1058396] Tue, 14 May 2013 18:17 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
OK, I got an AUTs (Mail template) to work, that is, I got Object Mapping Mode to be enabled and the AUT to be displayed within the Running AUTs view. The solution was to build the Mail template with Eclipse 3.6 Helios.

However, this is not my target environment since my AUT is Eclipse Kepler 4.3M7. Your website says that standalone Jubula 2.0 is a Kepler Preview. I assume that means that Jubula is built upon Kepler.

Can you confirm that I should be able to test Eclipse Kepler 4.3M7 with it?

To help me debug this problem with Eclipse Kepler can you tell me how to enable your internal logger to write debug to stdout? Thanks.

[Updated on: Wed, 15 May 2013 11:42]

Report message to a moderator

Re: Object Mapping Mode always disabled [message #1058901 is a reply to message #1058753] Wed, 15 May 2013 11:38 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
The Mail template built with Eclipse 4 shows the following Plug-ins:

org.eclipse.jubula.rc.rcp
org.eclipse.jubula.rc.rcp.common
org.eclipse.jubula.rc.rcp.e4
org.eclipse.jubula.rc.rcp.e4.swt
org.eclipse.jubula.rc.rcp.swt

The Mail template built with Eclipse 3 shows the following Plug-ins:

org.eclipse.jubula.rc.rcp
org.eclipse.jubula.rc.rcp.common
org.eclipse.jubula.rc.rcp.e3
org.eclipse.jubula.rc.rcp.e3.specific
org.eclipse.jubula.rc.rcp.swt

All with version/date of 2.0.0.201303141505. I don't know if this helps...

[Updated on: Wed, 15 May 2013 11:41]

Report message to a moderator

Re: Object Mapping Mode always disabled [message #1058984 is a reply to message #1058901] Thu, 16 May 2013 02:56 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1055
Registered: July 2009
Senior Member
Hi Brian,

Thanks for the extra details! Your mention of Kepler jogged my memory - in the 2.0 version, we added support for e4, but there was still a problem with testing Kepler AUTs. There was a ticket with details (and also a partial patch) that has now been resolved.

Long story short: if you can adapt your files as described in the ticket, then you should be able to make it work now. Otherwise, it's in the Kepler release.

Hope that helps - let us know if you run into any other questions!
Alex
Re: Object Mapping Mode always disabled [message #1059144 is a reply to message #1058984] Thu, 16 May 2013 20:50 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
Thanks Alex that was a step in the right direction. I created a modified rcp-support.zip with the two updated jar files in it from the bug you linked to in your reply. Now I am encountering a network/hostname problem that is my responsibility to fix here, which I will do tomorrow morning. So object mapping is still not fully alive yet, but now the progress bar completes and the AUT is listed in Running AUTs, but it fails when the AUT tries to connect back to Jubula using the hostname passed in one of its messages. But as I said earlier the Jubula node's hostname is misconfigured, that is, it is not a FQDN, and I need to fix it. Thanks so far for your help.
Re: Object Mapping Mode always disabled [message #1059147 is a reply to message #1059144] Thu, 16 May 2013 21:00 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
Alex earlier you said "- You said the main window, but I'm going to ask anyway : does the AUT have a splash screen? If so, then you should configure the workspace path in the AUT Configuration". Can you tell me why you should configure the workspace path in the AUT Configuration? Is it possible to test/control the GUI with Jubula during workspace entry/selection dialog prior to the Eclipse main window appearing?
Re: Object Mapping Mode always disabled [message #1059173 is a reply to message #1059147] Fri, 17 May 2013 02:33 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1055
Registered: July 2009
Senior Member
Hi,

Glad that you're making progress Smile thanks for the update.

Re splash screens - basically, the plugins required to make the AUT testable (the rc.rcp.* ones) aren't loaded at the point when the splash screen is shown, making it non-testable. Using an AUT argument -data "<WORKSPACE"> ensures that the correct workspace is chosen, and that the workspace dialog doesn't appear.

HTH!
Alex
Re: Object Mapping Mode always disabled [message #1059241 is a reply to message #1059173] Fri, 17 May 2013 08:57 Go to previous message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
That is what I thought. Thanks.
Previous Topic:import gives strange error
Next Topic:Unique index or primary key violation
Goto Forum:
  


Current Time: Sat Apr 19 18:34:21 EDT 2014

Powered by FUDForum. Page generated in 0.23440 seconds