Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Egit will not install on Juno (Tried from the update site and from a download)
Egit will not install on Juno [message #1058178] Mon, 13 May 2013 01:12 Go to next message
Tom Quinn is currently offline Tom Quinn
Messages: 2
Registered: July 2009
Junior Member
I have not been able to install eGit.

Using this site eGit - http://download.eclipse.org/egit/updates
and this
Juno - http://download.eclipse.org/releases/juno
and this file
org.eclipse.egit.repository-2.3.1.201302201838-r.zip

I get the following (or similar)

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse EGit 2.3.1.201302201838-r (org.eclipse.egit.feature.group 2.3.1.201302201838-r)
Software currently installed: EGit Project Set Support 2.1.0.201209190230-r (org.eclipse.egit.psf.feature.group 2.1.0.201209190230-r)
Only one of the following can be installed at once:
Git Team Provider Core 2.3.1.201302201838-r (org.eclipse.egit.core 2.3.1.201302201838-r)
Git Team Provider Core 2.1.0.201209190230-r (org.eclipse.egit.core 2.1.0.201209190230-r)
Cannot satisfy dependency:
From: Eclipse EGit 2.3.1.201302201838-r (org.eclipse.egit.feature.group 2.3.1.201302201838-r)
To: org.eclipse.egit.core [2.3.1.201302201838-r]
Cannot satisfy dependency:
From: EGit Project Set Support 2.1.0.201209190230-r (org.eclipse.egit.psf.feature.group 2.1.0.201209190230-r)
To: org.eclipse.egit.core [2.1.0,2.2.0)

Also to note, I scanned my eclipse folder and removed all files with egit and jgit in them... so I do not know where the conflict could be coming from.

Thanks for any help.
Re: Egit will not install on Juno [message #1058591 is a reply to message #1058178] Tue, 14 May 2013 10:05 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 491
Registered: July 2009
Senior Member
Don't delete bundles by deleting them from the installation folder, this may corrupt your
installation's p2 meta data needed for updates and installation/uninstallation of features.
Instead uninstall them.

In order to fix this concrete case you may try to uninstall the 2.1 org.eclipse.egit.psf feature.
This feature was removed and its functionality is now included in the egit core feature.
Re: Egit will not install on Juno [message #1058636 is a reply to message #1058591] Tue, 14 May 2013 11:10 Go to previous messageGo to next message
Tom Quinn is currently offline Tom Quinn
Messages: 2
Registered: July 2009
Junior Member
Thanks very much for the reply.

I solved my problem by upgrading from Windows XP to Ubuntu 12.04 lts.

For the future, if I do not delete bundles by removing them from the installation folders, how do I uninstall?
Re: Egit will not install on Juno [message #1060337 is a reply to message #1058636] Fri, 24 May 2013 04:15 Go to previous message
Stefan Lay is currently offline Stefan Lay
Messages: 338
Registered: July 2009
Senior Member
Uninstalling features is described here: http://wiki.eclipse.org/FAQ_How_do_I_remove_a_plug-in%3F
Previous Topic:Merge Tool
Next Topic:http.sslcainfo config option
Goto Forum:
  


Current Time: Mon Apr 21 05:53:21 EDT 2014

Powered by FUDForum. Page generated in 0.04235 seconds