Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » Update error
Update error [message #1057955] Fri, 10 May 2013 05:32 Go to next message
Enrico R. is currently offline Enrico R.Friend
Messages: 43
Registered: July 2009
Location: Germany


trying to update Kepler (4.3.0 I20130314-1330) to M7 but i always get an error dialog saying:

An error occurred while uninstalling
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Uninstall, operand=[R]org.eclipse.sdk.ide.executable.win32.win32.x86_64 4.3.0.I20130314-1330 --> null, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.CleanupzipAction).
Backup of file D:\installed\Eclipse\E_4.3_x64\eclipse.exe failed.
Can not remove : D:\installed\Eclipse\E_4.3_x64\eclipse.exe

My eclipse.ini:

Running Win7 64Bit with 64Bit JDK7u21 as administrator and i'm using updatesite "".
My anti-virus has an exception for my hole eclipse folder.
I checked all handles (processes) using 'eclipse.exe' and there 'eclipse.exe' itself, 'java.exe' and 'csrss.exe' (Client/Server Runtime Subsystem from Windows, its used for the console and threading under Windows).

I found a bugreport with the same issue but no solution for my case.

Has anybody an idea ho to solve this except of make a clean eclipse installation?

Re: Update error [message #1058194 is a reply to message #1057955] Mon, 13 May 2013 07:49 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot CelaFriend
Messages: 597
Registered: December 2010
Senior Member

You may have more luck asking in the P2 forums because you can see P2 complaining it can not remove a file. Initially looks like a permission issue but as you state it is not the case.
Re: Update error [message #1127916 is a reply to message #1057955] Mon, 07 October 2013 06:23 Go to previous messageGo to next message
Premysl Fiala is currently offline Premysl FialaFriend
Messages: 2
Registered: October 2012
Junior Member
I had same issue with updating Kepler. W7 with admin.

How to solve:

  1. Run eclipse
  2. Rename eclipse exe to eclipse.exe.back
  3. Run updates
  4. Updates executed successfully

Re: Update error [message #1238305 is a reply to message #1057955] Sat, 01 February 2014 00:14 Go to previous messageGo to next message
Luke Usherwood is currently offline Luke UsherwoodFriend
Messages: 10
Registered: July 2009
Junior Member
Thanks Premysl! Worked nicely, updating from 4.4M3 -> 4.4M5.

(First time I've seen that...)
Re: Update error [message #1385306 is a reply to message #1057955] Thu, 05 June 2014 13:48 Go to previous messageGo to next message
Zia Rehman is currently offline Zia RehmanFriend
Messages: 1
Registered: June 2014
Junior Member
make a new workspace then try with the kepler. it doesnot work in old workspace. worked for me.
icon11.gif  Re: Update error [message #1517299 is a reply to message #1385306] Fri, 19 December 2014 11:58 Go to previous message
Dion Staiger is currently offline Dion StaigerFriend
Messages: 1
Registered: December 2014
Junior Member
in the terminal

sudo exclipse

the problem is the program does not have permision to update the files
Previous Topic:Update E4 RCP application with Launcher Name fails
Next Topic:Can't connect to update site
Goto Forum:

Current Time: Wed Nov 25 20:26:29 GMT 2015

Powered by FUDForum. Page generated in 0.11054 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software