Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Where to find old GWT Designer
Where to find old GWT Designer [message #1057944] Thu, 09 May 2013 20:15 Go to next message
Calin Medianu is currently offline Calin Medianu
Messages: 12
Registered: July 2009
Junior Member
Hi,

I need to maintain a legacy application that is written with GWT 1.7.1. What is the latest GWT Designer that still supports GWT 1.7.1? Where can I download it?

Thanks in advance,

Calin
Re: Where to find old GWT Designer [message #1058058 is a reply to message #1057944] Fri, 10 May 2013 13:13 Go to previous messageGo to next message
Michael Prentice is currently offline Michael Prentice
Messages: 22
Registered: October 2012
Location: Melbourne, FL
Junior Member
Here are some old links for Eclipse 3.5, 3.6, 3.7. Not sure about their support for which version of GWT though:

https://developers.google.com/web-toolkit/tools/download-gwtdesigner

Oh here's one for Eclipse 3.4:
https://developers.google.com/web-toolkit/tools/gwtdesigner/installation/updatesite_3.4


Michael Prentice
GDG Space Coast

[Updated on: Fri, 10 May 2013 13:17]

Report message to a moderator

Re: Where to find old GWT Designer [message #1058060 is a reply to message #1058058] Fri, 10 May 2013 13:22 Go to previous messageGo to next message
Calin Medianu is currently offline Calin Medianu
Messages: 12
Registered: July 2009
Junior Member
Thanks Michael,

I already tried those. They are new GWT Designers for old Eclipse. I need the old GWT designer.

It's disappointing that Google dropped support for the old GWT and doesn't even make available an old version of the software, or an easy way to find it.

Re: Where to find old GWT Designer [message #1058062 is a reply to message #1058060] Fri, 10 May 2013 13:32 Go to previous message
Michael Prentice is currently offline Michael Prentice
Messages: 22
Registered: October 2012
Location: Melbourne, FL
Junior Member
Bummer. Looks like the WindowBuilderPro links to the same thing too

http://dl.google.com/eclipse/inst/d2wbpro/latest/3.5

Seem to all be 2012 versions, post-open sourcing and during period of donation to Eclipse.

I'm not sure if any of the previous versions were open source.

Looks like GWT has a good list of old releases available here: https://developers.google.com/web-toolkit/versions

But I don't see anything about GWT Designer which I don't think is part of the SDK.

So I wouldn't say that Google dropped support for the old versions of GWT. But you do have a case for saying that support for old versions of GWT Designer has been lacking or apparently does not exist.

No one at your company has a copy of an Eclipse install with the tools configured for that product?

Lots of things have changed and been deprecated (for multiple releases/years) since GWT 1.7.1. That sounds like quite a project you have ahead of you. Good luck!


Michael Prentice
GDG Space Coast

[Updated on: Fri, 10 May 2013 13:34]

Report message to a moderator

Previous Topic:Launch configuration BreakDictionary references non-existing project.
Next Topic:WindowBuilder Bug. Control position in Designer View is opposite
Goto Forum:
  


Current Time: Sun Apr 20 02:55:55 EDT 2014

Powered by FUDForum. Page generated in 0.01781 seconds