Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Error trying to run debugger(Error in final launch sequence)
icon9.gif  Error trying to run debugger [message #1053856] Tue, 07 May 2013 21:32 Go to next message
Tim Anderson is currently offline Tim Anderson
Messages: 19
Registered: April 2011
Junior Member
Eclipse Information
Eclipse IDE for Parallel Application Developers
Version: Indigo Service Release 2
Build Id: 20120216-1857
CDT Version: 8.0.2.201202111925
GDB Common Version: 7.0.0.201202111925
Photran Version: 7.0.0.201202151942

Operating System
Red Hat Enterprise Linux Workstation
Release 6.3 (Santiago)
Kernel Linux 2.6.32-279.14.1.el6.x86_64
GNOME 2.28.2

$ gdb --version
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-60.el6)
License GPLv3+: GNU GPL version3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.

Problem
When trying to start the debugger, I get a popup message titled "Problem Occurred" which says:
'Launching MyTest Debug' has encoutered a problem.
Error in final launch sequence

In the details section is the following:
Error in final launch sequence
File to execute MI command:
maintenance set python print-stack off
Error message from debugger back end:
Undefined maintenance set python command: "print-stack off". Try "help maintenance set python".
Undefined maintenance set python command: "print-stack off". Try "help maintenance set python".

Could it be that there is some kind of configuration problem between Eclipse and GDB?

Unfortunately, I do not have root access to my machine so anything that needs to be done will require my System Administrator.
Re: Error trying to run debugger [message #1057735 is a reply to message #1053856] Wed, 08 May 2013 13:50 Go to previous messageGo to next message
Axel Mueller is currently offline Axel Mueller
Messages: 1964
Registered: July 2009
Senior Member
see https://bugs.eclipse.org/bugs/show_bug.cgi?id=403213

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: Error trying to run debugger [message #1057743 is a reply to message #1057735] Wed, 08 May 2013 14:13 Go to previous message
Tim Anderson is currently offline Tim Anderson
Messages: 19
Registered: April 2011
Junior Member
Thanks. I should have figured that out since we recently upgraded the version of GDB.
Previous Topic:Eclipse 4.2.2: Build through API suspends output of build console until the end of build
Next Topic: remote debugging in eclipse cdt from linux server using cygwin
Goto Forum:
  


Current Time: Sun Oct 26 05:05:14 GMT 2014

Powered by FUDForum. Page generated in 0.34617 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software