Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to up Check for Updates (Error occurs when attempting to update)
Unable to up Check for Updates [message #1053843] Tue, 07 May 2013 19:56 Go to next message
Jason Anderson is currently offline Jason AndersonFriend
Messages: 3
Registered: May 2013
Junior Member
Eclipse IDE for Java Developers

Version: Helios Release
Build id: 20100617-1415

Windows 7 64 bit PC

I am using v3.6 32 bit because I need this version for a particular plugin.

When I attempt to Check for Updates from the Help menu I get the error below. I get the same error when I use Install New Software from the same menu.

What I have done so far is some searching and it seems the forums are suggesting to use JRE 1.6 to get around this bug. So, I have downloaded JRE 1.6 64 bit, changed my Java preferences to use this JRE, and I get the same error.

So then I think well maybe since I have the 32 bit version of Eclipse I should install JRE 1.6 32 bit into Program Files (x86) and change it to use that and I get the same error.

I'm new to this forum so I apologize if I have not found something that is already out there.

java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product
Command-line arguments: -os win32 -ws win32 -arch x86 -product

!ENTRY 4 2 2013-05-07 15:36:02.830
!MESSAGE An internal error occurred during: "Install download0".
java.lang.IllegalArgumentException: Comparison method violates its general contract!
at java.util.ComparableTimSort.mergeHi(Unknown Source)
at java.util.ComparableTimSort.mergeAt(Unknown Source)
at java.util.ComparableTimSort.mergeForceCollapse(Unknown Source)
at java.util.ComparableTimSort.sort(Unknown Source)
at java.util.ComparableTimSort.sort(Unknown Source)
at java.util.Arrays.sort(Unknown Source)
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorSelector.hasValidMirror(
at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(
at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.getArtifact(
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transferSingle(
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transfer(
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.perform(
at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(

Re: Unable to up Check for Updates [message #1057741 is a reply to message #1053843] Wed, 08 May 2013 14:07 Go to previous message
Jason Anderson is currently offline Jason AndersonFriend
Messages: 3
Registered: May 2013
Junior Member
I was finally able to fix this by adding this line:


to the eclipse.ini file after -vmargs

Previous Topic:Plugin project creation using Maven?
Next Topic:Cannot start eclipse juno (No java virtual machine error)
Goto Forum:

Current Time: Mon Oct 05 17:19:51 GMT 2015

Powered by FUDForum. Page generated in 0.01569 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software