Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » How to tell virgo to deploy my configurations first with eclipse tooling?(How to tell virgo to deploy my configurations first with eclipse tooling?)
How to tell virgo to deploy my configurations first with eclipse tooling? [message #1053394] Sun, 05 May 2013 02:39 Go to next message
Jay Huang is currently offline Jay HuangFriend
Messages: 20
Registered: February 2012
Junior Member
Hi, I have some bundles and each has a configuration artifact, in development, I put the configs in VIRGO_SERVER/pickup , and start the server from eclipse. My problem is that virgo sometimes does not start my configs first hence causing the bundle fail to start.

Is there a way to make the configs started first? Or What is the proper way to use config artifacts in eclipse? I understand that in production deployment I can control the order using plans, but can I use plans in eclipse?

Thank you.
Re: How to tell virgo to deploy my configurations first with eclipse tooling? [message #1058247 is a reply to message #1053394] Mon, 13 May 2013 10:50 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
You could deploy the configs via the initialArtifacts property described in the Virgo User Guide.
Re: How to tell virgo to deploy my configurations first with eclipse tooling? [message #1058769 is a reply to message #1058247] Wed, 15 May 2013 01:33 Go to previous messageGo to next message
Jay Huang is currently offline Jay HuangFriend
Messages: 20
Registered: February 2012
Junior Member
Problem solved, Thanks Glyn
Re: How to tell virgo to deploy my configurations first with eclipse tooling? [message #1058812 is a reply to message #1058769] Wed, 15 May 2013 08:38 Go to previous message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
You're welcome!
Previous Topic:Spring Web (3.2.2) + Jackson (1.9)
Next Topic:java.lang.NoClassDefFoundError: org/codehaus/jackson/map/ObjectMapper
Goto Forum:
  


Current Time: Thu Nov 27 04:49:03 GMT 2014

Powered by FUDForum. Page generated in 0.04592 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software