Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » File has an invalid content (org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505.jar)
File has an invalid content (org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505.jar) [message #1052959] Wed, 01 May 2013 14:55 Go to next message
Jiri Janecek is currently offline Jiri JanecekFriend
Messages: 12
Registered: February 2011
Junior Member
Hi all,

few days ago I ran into serious troubles when building our product against our indigo mirror using Maven3.

Originally when fetching artifacts during build process Maven was complaining junit3.8.2 bundle has an invalid content. I was playing three days trying to determine where is source of the problem without success.

Finally I tried to mirror locally Indigo and build against this local mirror. Build succeeds until I try to build x86_64 linux bundle. In this case Maven is complaining

[exec] org.apache.maven.InternalErrorException: Internal error: java.lang.RuntimeException: "Messages while trying children repositories.": ["": ["Problems downloading artifact: osgi.bundle,org.eclipse.equinox.launcher.gtk.linux.x86_64,1.1.100.v20110505.": ["File has invalid content:/tmp/signatureFile1242564987444501337.jar": ["Invalid content:launcher.gtk.linux.x86_64.properties", "Invalid content:META-INF/eclipse.inf", "Invalid content:about.html"]]]]


Any help will be really appreciated this is blocking me.

Thanks

Jiri



Re: File has an invalid content (org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505.jar [message #1053494 is a reply to message #1052959] Mon, 06 May 2013 09:34 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1395
Registered: July 2009
Senior Member
Hi

if you're using Java 7 then this might be related to this bug

https://bugs.eclipse.org/bugs/show_bug.cgi?id=361628

hope this helps
Lorenzo

On 05/01/2013 04:55 PM, Jiri Janecek wrote:
> Hi all,
>
> few days ago I ran into serious troubles when building our product
> against our indigo mirror using Maven3.
> Originally when fetching artifacts during build process Maven was
> complaining junit3.8.2 bundle has an invalid content. I was playing
> three days trying to determine where is source of the problem without
> success.
>
> Finally I tried to mirror locally Indigo and build against this local
> mirror. Build succeeds until I try to build x86_64 linux bundle. In this
> case Maven is complaining
>
> [exec] org.apache.maven.InternalErrorException: Internal error:
> java.lang.RuntimeException: "Messages while trying children
> repositories.": ["": ["Problems downloading artifact:
> osgi.bundle,org.eclipse.equinox.launcher.gtk.linux.x86_64,1.1.100.v20110505.":
> ["File has invalid content:/tmp/signatureFile1242564987444501337.jar":
> ["Invalid content:launcher.gtk.linux.x86_64.properties", "Invalid
> content:META-INF/eclipse.inf", "Invalid content:about.html"]]]]
>
>
> Any help will be really appreciated this is blocking me.
>
> Thanks
>
> Jiri
>
>
>
>


--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Re: File has an invalid content (org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505.jar [message #1053542 is a reply to message #1052959] Mon, 06 May 2013 13:02 Go to previous messageGo to next message
Jiri Janecek is currently offline Jiri JanecekFriend
Messages: 12
Registered: February 2011
Junior Member
I tried to verify mentioned jar file by the help of jar signer with following result

jarsigner -certs -verify -verbose ~/launcher/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505.jar 

         971 Wed Jun 29 09:28:24 CEST 2011 META-INF/MANIFEST.MF
         476 Wed Jun 29 09:28:24 CEST 2011 META-INF/ECLIPSEF.SF
        5639 Wed Jun 29 09:28:24 CEST 2011 META-INF/ECLIPSEF.RSA
           0 Wed Jun 29 08:50:56 CEST 2011 META-INF/
sm        76 Wed Jun 29 09:28:22 CEST 2011 META-INF/eclipse.inf

      [entry was signed on 6/29/11 3:28 PM]
      X.509, CN="Eclipse.org Foundation, Inc", OU=Digital ID Class 3 - Java Object Signing, O="Eclipse.org Foundation, Inc", L=Ottawa, ST=Ontario, C=CA
      [certificate expired on 4/14/12 1:59 AM]
      X.509, CN=VeriSign Class 3 Code Signing 2004 CA, OU=Terms of use at [url]https://www.verisign.com/rpa[/url] (c)04, OU=VeriSign Trust Network, O="VeriSign, Inc.", C=US
      [certificate is valid from 7/16/04 2:00 AM to 7/16/14 1:59 AM]
      [KeyUsage, NetscapeCertType extension does not support code signing]
      X.509, OU=Class 3 Public Primary Certification Authority, O="VeriSign, Inc.", C=US
      [certificate is valid from 1/29/96 1:00 AM to 8/2/28 1:59 AM]

sm      1445 Wed Jun 29 08:50:56 CEST 2011 about.html

      [entry was signed on 6/29/11 3:28 PM]
      X.509, CN="Eclipse.org Foundation, Inc", OU=Digital ID Class 3 - Java Object Signing, O="Eclipse.org Foundation, Inc", L=Ottawa, ST=Ontario, C=CA
      [certificate expired on 4/14/12 1:59 AM]
      X.509, CN=VeriSign Class 3 Code Signing 2004 CA, OU=Terms of use at [url]https://www.verisign.com/rpa[/url] (c)04, OU=VeriSign Trust Network, O="VeriSign, Inc.", C=US
      [certificate is valid from 7/16/04 2:00 AM to 7/16/14 1:59 AM]
      [KeyUsage, NetscapeCertType extension does not support code signing]
      X.509, OU=Class 3 Public Primary Certification Authority, O="VeriSign, Inc.", C=US
      [certificate is valid from 1/29/96 1:00 AM to 8/2/28 1:59 AM]

sm    187935 Wed Jun 29 08:50:56 CEST 2011 eclipse_1407.so

      [entry was signed on 6/29/11 3:28 PM]
      X.509, CN="Eclipse.org Foundation, Inc", OU=Digital ID Class 3 - Java Object Signing, O="Eclipse.org Foundation, Inc", L=Ottawa, ST=Ontario, C=CA
      [certificate expired on 4/14/12 1:59 AM]
      X.509, CN=VeriSign Class 3 Code Signing 2004 CA, OU=Terms of use at [url]https://www.verisign.com/rpa[/url] (c)04, OU=VeriSign Trust Network, O="VeriSign, Inc.", C=US
      [certificate is valid from 7/16/04 2:00 AM to 7/16/14 1:59 AM]
      [KeyUsage, NetscapeCertType extension does not support code signing]
      X.509, OU=Class 3 Public Primary Certification Authority, O="VeriSign, Inc.", C=US
      [certificate is valid from 1/29/96 1:00 AM to 8/2/28 1:59 AM]

sm       620 Wed Jun 29 08:50:56 CEST 2011 launcher.gtk.linux.x86_64.properties

      [entry was signed on 6/29/11 3:28 PM]
      X.509, CN="Eclipse.org Foundation, Inc", OU=Digital ID Class 3 - Java Object Signing, O="Eclipse.org Foundation, Inc", L=Ottawa, ST=Ontario, C=CA
      [certificate expired on 4/14/12 1:59 AM]
      X.509, CN=VeriSign Class 3 Code Signing 2004 CA, OU=Terms of use at [url]https://www.verisign.com/rpa[/url] (c)04, OU=VeriSign Trust Network, O="VeriSign, Inc.", C=US
      [certificate is valid from 7/16/04 2:00 AM to 7/16/14 1:59 AM]
      [KeyUsage, NetscapeCertType extension does not support code signing]
      X.509, OU=Class 3 Public Primary Certification Authority, O="VeriSign, Inc.", C=US
      [certificate is valid from 1/29/96 1:00 AM to 8/2/28 1:59 AM]


  s = signature was verified 
  m = entry is listed in manifest
  k = at least one certificate was found in keystore
  i = at least one certificate was found in identity scope

jar verified.

Warning: 


This jar contains entries whose signer certificate has expired.

Please can smb. confirm this as bug?

Seems like this jar needs to be resigned.

Thanks

JJ

[Updated on: Mon, 06 May 2013 13:08]

Report message to a moderator

Re: File has an invalid content (org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505.jar [message #1053543 is a reply to message #1053542] Mon, 06 May 2013 13:03 Go to previous message
Jiri Janecek is currently offline Jiri JanecekFriend
Messages: 12
Registered: February 2011
Junior Member
Hi Lorenzo, no JDK 1.6 is installed, 1.7 seems to be very buggy.

[Updated on: Mon, 06 May 2013 13:08]

Report message to a moderator

Previous Topic:p2 director headless, can't find missing dependency from other repo.
Next Topic:Convert Dropins to Update site
Goto Forum:
  


Current Time: Wed Nov 26 17:53:39 GMT 2014

Powered by FUDForum. Page generated in 0.02833 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software