Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Plugin Development problems with EMF 2.8 and CDO 4.2
[CDO] Plugin Development problems with EMF 2.8 and CDO 4.2 [message #1052830] Tue, 30 April 2013 15:47
Per Sterner is currently offline Per SternerFriend
Messages: 77
Registered: October 2011
Member
Hello!

If you are using EMF < 2.9 and the newest CDO you may/will get problems with your Model-Plugin.

The problem is that the current Eclipse PDE won't handle osgi-fragments correctly. CDO uses an osgi-fragment bundle in order to produce a compatibility to EMF < 2.9. In the eclipse/osgi runtime this bundle works perfectly! But inside the Eclipse Workspace while developing, eclipse complains. The PDE "problem" is discussed here: Integrate the new MinimalEStoreEObjectImpl

Regards,

Per Sterner
Previous Topic:multiple xcore files
Next Topic:3 or 4 layers
Goto Forum:
  


Current Time: Mon Dec 22 00:06:11 GMT 2014

Powered by FUDForum. Page generated in 0.08000 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software