Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Databasedriver missing/not found
Databasedriver missing/not found [message #1049253] Thu, 25 April 2013 15:20 Go to next message
Florian Gieß is currently offline Florian Gieß
Messages: 1
Registered: April 2013
Junior Member
Hello,

i try to set up a automatic test environment, which is integrated in our build process. Therefor i am unsing an ANT-script to launch testexec via maven. its working quite good execpt i always get the following error message when building the package:

[INFO] Executing tasks
[exec] Thu Apr 25 17:08:36 CEST 2013 AUT Agent: Connecting to "jubula:60000" ...
[exec] Thu Apr 25 17:08:37 CEST 2013 AUT Agent: connection established.
[exec] Thu Apr 25 17:08:37 CEST 2013 Database: Connecting as "sa" to "jdbc:h2:\\jubula\c$\Users\username\.jubula\database\embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE"...
[exec] [EL Severe]: 2013-04-25 17:08:42.7--ServerSession(8960088)--Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.3.2.v20111125-r10461): org.eclipse.persistence.exceptions.DatabaseException
[exec] Internal Exception: java.sql.SQLException: No suitable driver found for jdbc:h2:\\jubula\c$\Users\username\.jubula\database\embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE
[exec] Error Code: 0
[exec] !!Error occurred !!
[exec] Database connection failed because of invalid or missing database detail
[exec] Thu Apr 25 17:08:42 CEST 2013 AUT Agent: connection closed.
[exec] Thu Apr 25 17:08:42 CEST 2013 Exit: Code 1


My configuration is:

<testSrv>\\jubula\c$</testSrv>
<userDir>${testSrv}\Users\username</userDir>

<testdata.dir>${testSrv}\jubula</testdata.dir>
<result.dir>${testSrv}\jubula\results</result.dir>
<workspace.dir>${testSrv}\jubula\workspace</workspace.dir>

<autrun>${testSrv}\Program Files (x86)\jubula_1.3.00071\server\autrun</autrun>
<testexec>${testSrv}\Program Files (x86)\jubula_1.3.00071\jubula\testexec</testexec>



<test.project>Projectname</test.project>
<test.project.version>1.0</test.project.version>
<test.job>Basictest</test.job>
<test.aut.id>my_aut</test.aut.id>
<autagent.host>jubula</autagent.host>
<autagent.port>60000</autagent.port>
<db.user>sa</db.user>
<db.url>jdbc:h2:${userDir}\.jubula\database\embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE</db.url>


...


<exec executable="${testexec}" failonerror="true">
<arg line='-project ${test.project} -version ${test.project.version} -testjob ${test.job}'/>
<arg line='-server ${autagent.host} -port ${autagent.port} -autid ${test.aut.id}'/>
<arg line='-datadir "${testdata.dir}" -resultdir "${result.dir}"'/>
<arg line='-data "${workspace.dir}"' />
<arg line='-language en_US -dburl "${db.url}"'/>
<arg line='-dbuser ${db.user} -dbpw \"\"'/>
</exec>

Does anyone have an idea how to resolve this problem? I tried including the h2*.jar in my project but it doesn't work. If i start testexec directly from the jubula-machine it works just fine...
Re: Databasedriver missing/not found [message #1051881 is a reply to message #1049253] Mon, 29 April 2013 10:18 Go to previous message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
It looks like you're missing the password for the database in your script. Information on using the configuration file is here.

Best regards,
Alex
Previous Topic:How to specify file paths in external commands?
Next Topic:Object Mapping not propagated from reused project
Goto Forum:
  


Current Time: Tue Oct 21 03:58:13 GMT 2014

Powered by FUDForum. Page generated in 0.02249 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software