Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Building an Eclipse Product for XText
Building an Eclipse Product for XText [message #1049013] Thu, 25 April 2013 08:24 Go to next message
Mårten Carlzon is currently offline Mårten Carlzon
Messages: 60
Registered: March 2013
Location: Sweden
Member

Hello folks,

I wanted again see if I could use your expertise.

I am trying to get my XText Eugenia project to only require 1 eclipse window so then I was told to try and use plugin projects. So I looked around a bit and found a tutorial and tried to follow that but I seem to have gotten stuck. (Its seems a bit outdated so maybe someone here knows a better way but we all have to start somewhere Smile)

After all the steps with the tutorial I get the following error message.
ErrorMessage


It says in the tutorial to check the plugins in the run configurations and I do that and try to validate the them but get tons of collisions [1].
I stumble over the nice button "Add Required Plug-ins" and from having 33 plugin-ins I have now 172 and now there is no errors when I validate the plug-ins.

Sad thing is, I still get that error message. Any idea what I might be missing?

I am using XText 2.4 so I have added the sdk in step 6 for instance and tests instead of generator on step 3.


Thanks for any help

Write you later / Mårten
Re: Building an Eclipse Product for XText [message #1049180 is a reply to message #1049013] Thu, 25 April 2013 13:27 Go to previous messageGo to next message
Erick Fonseca is currently offline Erick Fonseca
Messages: 68
Registered: December 2011
Member
I tried a simpler way, and it worked. Right click your DSL project and select "Export...". Then, choose "Deployable plug-ins and fragments". In the next screen, set the output directory to where Eclipse is installed. And in the Options tab, check "use class files compiled in the workspace" (at least for me it wouldn't work if I didn't check this). Then hit Finish and it should work.
Re: Building an Eclipse Product for XText [message #1051984 is a reply to message #1049180] Mon, 29 April 2013 13:22 Go to previous message
Mårten Carlzon is currently offline Mårten Carlzon
Messages: 60
Registered: March 2013
Location: Sweden
Member

Hello Erick

Sorry for the late reply, but thanks for the tips.
I tried to do as you did and placed the output where I had an empty eclipse, I can see the jar files there but when I open eclipse I am unable to see them in the plug-in section on installed features and when I make a mydsl file nothing happens.

So I tried to make an updatesite (according to this site) instead and managed to do it that way but with one error, I seem to loose auto-complete that way. It works nice when I just make a new launch window but not in one that I have installed my feature through the update-site. Anyone has any ideas why this is so?
Previous Topic:cross reference / multiple files / JvmModelInferer
Next Topic:Inserting Comments at the Top of an XText Resource at Serialization Time
Goto Forum:
  


Current Time: Thu Oct 23 14:30:11 GMT 2014

Powered by FUDForum. Page generated in 0.02477 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software