Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » modules don't get loaded into interactive-shell [SOLVED](python)
modules don't get loaded into interactive-shell [SOLVED] [message #1048719] Wed, 24 April 2013 17:51 Go to next message
Jim Kay is currently offline Jim Kay
Messages: 2
Registered: April 2013
Junior Member
still trying to set up Eclipse correctly (with pydev) for python.

after running/loading a module, the interactive-shell doesn't recognize the variables from my program.
I want it to be able to, so I can test the programs I write in an interactive console.

(from the screenshot you can see that I tried to call "var1" but error occured)

am I doing something wrong? I'm sure this is a very newbie question. thank you for any answers

[Updated on: Thu, 25 April 2013 18:08]

Report message to a moderator

Re: modules don't get loaded into interactive-shell [message #1049268 is a reply to message #1048719] Thu, 25 April 2013 11:44 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3125
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 4/25/2013 7:06 AM, Jim Kay wrote:
> still trying to set up Eclipse correctly (with pydev) for python.
>
> after running/loading a module, the interactive-shell doesn't recognize the variables from my program.
> I want it to be able to, so I can test the programs I write in an interactive console.
>
> (from the screenshot you can see that I tried to call "var1" but error occured)
>
> am I doing something wrong? I'm sure this is a very newbie question. thank you for any answers

This is probably more appropriately asked in a (the) PyDev forum. If you
don't get an answer here, this is why.
Re: modules don't get loaded into interactive-shell [message #1049454 is a reply to message #1049268] Thu, 25 April 2013 18:06 Go to previous message
Jim Kay is currently offline Jim Kay
Messages: 2
Registered: April 2013
Junior Member
after a ton of google searching (over the span of two days) I finally found the solution.

the pydev interactive shell in Eclipse is oblivious to your projects/modules until you load it into the shell by using this command: execfile('/home/pathtoyourmodule/eclipsework/Project 1/Module1.py')

a short-cut is using the hotkey ctrl+alt+enter while your program/module is in focus. (this will auto-load it into the interactive-shell)

this applies to Eclipse 3.8.0


P.S. there is no official PyDev forum, only a few un-official discussion boards that look like ghost-towns

[Updated on: Thu, 25 April 2013 18:09]

Report message to a moderator

Previous Topic:Error msg: No command output when running
Next Topic:Remote Debugging Win7
Goto Forum:
  


Current Time: Fri Jul 25 14:18:12 EDT 2014

Powered by FUDForum. Page generated in 0.01584 seconds