Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Help with xpath please(can anyone show me the correct xpath for my dataSet ?)
Help with xpath please [message #1048247] Wed, 24 April 2013 04:08 Go to next message
Cyril Rognon is currently offline Cyril Rognon
Messages: 24
Registered: July 2010
Junior Member
Hi all,

I have posted some question about xpath/xml datasource issue.
I reckon my text was complex and not easy to answer.

Now I have setup a sample report and a sample xml source to show the issue

I try to select a value from a node depending on some value with a predicate filter.
It does not work.

Attached report design and xml sample is minimalist and show only the problem.
V and V1 are two ways of xpath predicate. All this works in standard xpath (checked) but not in Birt.

Anyone can help me please ?

Regards,
Cyril
Re: Help with xpath please [message #1048654 is a reply to message #1048247] Wed, 24 April 2013 15:42 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1424
Registered: July 2009
Senior Member

EDIT: I posted on this one by accident with a response to your other XPath question. I'm not sure if they're asking the same thing, so I added the response to the other post and will look at this one, now. Smile

Michael
Actuate – The BIRT Company™

BIRT Developer Center
Check out the new, free BIRT Viewer Toolkit

[Updated on: Wed, 24 April 2013 15:48]

Report message to a moderator

Re: Help with xpath please [message #1048665 is a reply to message #1048654] Wed, 24 April 2013 15:56 Go to previous message
Michael Williams is currently offline Michael Williams
Messages: 1424
Registered: July 2009
Senior Member

After looking at this one, it looks like it's the same. Please refer to the answer in the other post: http://www.eclipse.org/forums/index.php/t/481559/

Michael
Actuate – The BIRT Company™

BIRT Developer Center
Check out the new, free BIRT Viewer Toolkit
Previous Topic:Xpath issue with xml datasource
Next Topic:flash builder required 3.7 or above version eclipse plugin
Goto Forum:
  


Current Time: Wed Apr 16 12:01:55 EDT 2014

Powered by FUDForum. Page generated in 0.02349 seconds