Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » UML profile as metamodel in standalone(howto use UML profile in ATL standalone)
icon5.gif  UML profile as metamodel in standalone [message #1039576] Fri, 12 April 2013 10:04 Go to next message
Mathias Colpaert is currently offline Mathias ColpaertFriend
Messages: 13
Registered: November 2012
Junior Member
Is it possible to use an UML profile in a standalone ATL application?

If so, what steps do I need to go through in the initialization of my transformation?

I have registered the UML metamodel and my target metamodel (custom ecore), but I get an error upon loading the UML model:

Quote:
Package with uri 'http:///schemas/UWEProfile/_-k3sQKDiEeKjH5AcJM1Odg/0' not found. (file:///C:/Users/Mathias/workspaces/workspaceEclipse/UWE%20models/twitter.uml, 78, 99)


Regards,
M
Re: UML profile as metamodel in standalone [message #1039583 is a reply to message #1039576] Fri, 12 April 2013 10:14 Go to previous message
Mathias Colpaert is currently offline Mathias ColpaertFriend
Messages: 13
Registered: November 2012
Junior Member
Of course 2 minutes after posting, I find my error.

The problem was accualy in the inputmodel. It was because I was simultaneously creating the profile and a model to test it. But when you update/extend the profile, a new "version" is made. The model used to test, still contains references to the "old" version, and so this gives a reference error!
Previous Topic:[ATL] Cannot import EMFTVM
Next Topic:Get the value of MARTE element
Goto Forum:
  


Current Time: Sun Dec 21 14:35:05 GMT 2014

Powered by FUDForum. Page generated in 0.01477 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software