Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problem with Whitespaces / MacOSX (Illegal Character)
Problem with Whitespaces / MacOSX (Illegal Character) [message #1038969] Thu, 11 April 2013 15:02 Go to next message
Simon Lischka is currently offline Simon Lischka
Messages: 2
Registered: April 2013
Junior Member
Hi guys!
I have a strange issue with Eclipse Juno (20120920-0800) / OSX 10.7.5.
When writing code ( no copy & paste ) the editor randomly generates whitespace characters that are detected as "Illegal Character" by the compiler. Only when deleting the space and hitting space again the error disappears. Strangely this only happens when declaring a method header.

I have the default US-ASCII encoding + Unix file line delimiter set up.

Does anyone know a quick way to resolve this issue?


Thanks in advance -

Kind Regards,

Simon
Re: Problem with Whitespaces / MacOSX (Illegal Character) [message #1050979 is a reply to message #1038969] Sun, 28 April 2013 02:59 Go to previous message
Simon Lischka is currently offline Simon Lischka
Messages: 2
Registered: April 2013
Junior Member
Solved - Apparently this always happened when alt+space was pressed. Changing the Keybindings does the trick:

(Quoted from superuser.com)

Make your ~/Library/KeyBindings/DefaultKeyBinding.dict file look like this (if it doesn't exist create it, if there are already bindings in it just add the one from below):

{
"~ " = ("insertText:", " ");
}

What does this do? Every time you press Option-Space instead of inserting a non breaking space OS X now inserts a regular space. Problem fixed.


Previous Topic:Custom Editor with standard Java features
Next Topic:Eclipse with Phonegap
Goto Forum:
  


Current Time: Tue Oct 21 00:33:40 GMT 2014

Powered by FUDForum. Page generated in 0.01833 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software