Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Run control not available
Run control not available [message #1038922] Thu, 11 April 2013 10:09 Go to next message
tomer tomer is currently offline tomer tomer
Messages: 2
Registered: April 2013
Junior Member
Everytime i try to run my program is gets stuck, you know "mtm1.exe stop responding..."
and i get a "close program button" like it does when there is a SEGFAULT, thing is when i run it in debug its ok untill after the last line in main, the } after return 0, then it gives me:
No source available for "__mingw_CRTStartup() at 0x4010fd"
and if i keep holding down the F5 button (Step into) and it keeps giving me a variety of errors untill eventually it gives me an error message on the screen "Run control not available".
Tried running my program on my UBUNTU machine and it works fine.....
Im using windows by the way with MinGW and Eclipse CDT,
please help...
thanks.
Re: Run control not available [message #1039102 is a reply to message #1038922] Thu, 11 April 2013 15:17 Go to previous message
David Wegener is currently offline David Wegener
Messages: 1336
Registered: July 2009
Senior Member
This is the startup code for the executable that then calls your main method. Unless you are trying to debug mingw startup code. there is no reason to step into this code. Just hit the Run button and your program will exit.
Previous Topic:stdout not Displayed with Command Line Arguments
Next Topic:Can't run C programs properly
Goto Forum:
  


Current Time: Sat Aug 23 09:29:14 EDT 2014

Powered by FUDForum. Page generated in 0.01525 seconds