Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Getting "listen failed" error
Getting "listen failed" error [message #1038048] Wed, 10 April 2013 10:40 Go to next message
Ricardo West is currently offline Ricardo WestFriend
Messages: 6
Registered: April 2013
Junior Member
Hi!
Recently I found out eclipse Indigo cannot debug the same code twice. I can debug normally for the first time you start eclipse, when I do it for the second time, eclipse give me an error "Problem occurred:Cannot connect to VM. Permission denied: listen failed",but if I run it instead of debugging it, everything is OK.
index.php/fa/14320/0/
It is a very simple java app, and the problem occurs again if I debug this without any breakpoints:
public class Test
{
  public static void main(String[] args)
    {
        System.out.println("Testing");
    }
}

My OS is Windows 7 and the Java SE 1.7 installed. I try to re-install the latest Java 1.7 and eclipse Juno classic, even try to install the Java SE 1.6,but the problem is still there. Does any one know how to fix this?
  • Attachment: error.jpg
    (Size: 23.30KB, Downloaded 276 times)
Re: Getting "listen failed" error [message #1043062 is a reply to message #1038048] Wed, 17 April 2013 08:13 Go to previous messageGo to next message
Ricardo West is currently offline Ricardo WestFriend
Messages: 6
Registered: April 2013
Junior Member
Please help
Re: Getting "listen failed" error [message #1043207 is a reply to message #1043062] Wed, 17 April 2013 12:25 Go to previous messageGo to next message
Luigi P is currently offline Luigi PFriend
Messages: 10
Registered: April 2013
Location: Italy
Junior Member

Have you some exceptions in console?
Re: Getting "listen failed" error [message #1044142 is a reply to message #1043207] Thu, 18 April 2013 14:39 Go to previous messageGo to next message
Ricardo West is currently offline Ricardo WestFriend
Messages: 6
Registered: April 2013
Junior Member
Not at all. The error shows as soon as I click the debug button.
Re: Getting "listen failed" error [message #1044636 is a reply to message #1044142] Fri, 19 April 2013 06:44 Go to previous messageGo to next message
Luigi P is currently offline Luigi PFriend
Messages: 10
Registered: April 2013
Location: Italy
Junior Member

Can you post your debug configuration?
Re: Getting "listen failed" error [message #1045010 is a reply to message #1044636] Fri, 19 April 2013 16:35 Go to previous messageGo to next message
Ricardo West is currently offline Ricardo WestFriend
Messages: 6
Registered: April 2013
Junior Member
OK.Which part?
Re: Getting "listen failed" error [message #1045015 is a reply to message #1044636] Fri, 19 April 2013 16:42 Go to previous messageGo to next message
Ricardo West is currently offline Ricardo WestFriend
Messages: 6
Registered: April 2013
Junior Member
index.php/fa/14444/0/
index.php/fa/14445/0/
index.php/fa/14446/0/
index.php/fa/14447/0/
index.php/fa/14448/0/

Hope it helps.

[Updated on: Fri, 19 April 2013 16:49]

Report message to a moderator

Re: Getting "listen failed" error [message #1052970 is a reply to message #1045015] Wed, 01 May 2013 16:05 Go to previous message
Luigi P is currently offline Luigi PFriend
Messages: 10
Registered: April 2013
Location: Italy
Junior Member

The project that you are trying to debug is hosted in your local machine?
Previous Topic:Missing Editor
Next Topic:missing tomcat runtime environment
Goto Forum:
  


Current Time: Fri Nov 28 18:22:21 GMT 2014

Powered by FUDForum. Page generated in 0.02028 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software