Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » sudo: sorry, you must have a tty to run sudo
sudo: sorry, you must have a tty to run sudo [message #1035268] Sat, 06 April 2013 12:06 Go to next message
Alessandro Saracino is currently offline Alessandro Saracino
Messages: 4
Registered: March 2013
Junior Member
I've set HUDSON with a shell command that include "sudo"
But I've this error:
sudo: sorry, you must have a tty to run sudo

What I must do to resolve this problem?
It is installed on LINUX...
Re: sudo: sorry, you must have a tty to run sudo [message #1035284 is a reply to message #1035268] Sat, 06 April 2013 12:36 Go to previous message
Bob Foster is currently offline Bob Foster
Messages: 74
Registered: January 2013
Member
This is a Linux question. You have two issues. You need to be able to run sudo from a script; once you have that, you need to deal with the password. Below are a couple of links.

http://www.zimbra.com/forums/installation/10553-solved-sudo-sorry-you-must-have-tty-run-sudo.html

http://askubuntu.com/questions/155791/how-do-i-sudo-a-command-in-a-script-without-being-asked-for-a-password
Previous Topic:Failing the Hudson build in case of Java errors
Next Topic:GIT integration questions
Goto Forum:
  


Current Time: Thu Aug 28 09:27:48 EDT 2014

Powered by FUDForum. Page generated in 0.01604 seconds