Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » org.eclipse.ui.forms(Converting to e4)
org.eclipse.ui.forms [message #1034531] Fri, 05 April 2013 14:58 Go to next message
Jo Jaquinta is currently offline Jo Jaquinta
Messages: 40
Registered: January 2013
Location: Boston
Member

I'm building an e4 app for production. It's going to need a help system. While working on trying to remove the workbench dependencies from help I noticed that it also depends on forms, which depend on workbench. But while looking at forms I noticed that forms only needs workbench for a small number of classes to facilitate forms in Editors. Once I cloned the plugin and took that out, it worked fine as a pure e4 plugin.
It's not quite ready for prime time though. Forms still has its own system for styling the different elements. To be based on e4 "for real" those would have to be migrated to using CSS.
I just thought I'd check in and see if anyone else is doing work in this area. I don't want to re-invent the wheel if there's a solution out there.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Jo Grant, Senior Software Engineer
Admin and Config Console Architect
OpenPages, IBM
Re: org.eclipse.ui.forms [message #1034543 is a reply to message #1034531] Fri, 05 April 2013 15:11 Go to previous messageGo to next message
Dirk Fauth is currently offline Dirk Fauth
Messages: 1339
Registered: July 2012
Senior Member
Maybe this answers your question? http://www.vogella.com/blog/2013/04/02/using-eclipse-forms-in-eclipse-4-rcp/
Re: org.eclipse.ui.forms [message #1034553 is a reply to message #1034543] Fri, 05 April 2013 15:25 Go to previous messageGo to next message
Jo Jaquinta is currently offline Jo Jaquinta
Messages: 40
Registered: January 2013
Location: Boston
Member

Well, that probably saves my immediate trouble, but not my long term trouble of having forms depend on CSS. Since they aren't porting help anytime soon, and help uses forms, I'm probably stuck with help's dependence on forms. Thanks for the reference.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Jo Grant, Senior Software Engineer
Admin and Config Console Architect
OpenPages, IBM
Re: org.eclipse.ui.forms [message #1064953 is a reply to message #1034553] Fri, 21 June 2013 21:13 Go to previous message
Wim Jongman is currently offline Wim Jongman
Messages: 280
Registered: July 2009
Senior Member

Hi Jo,

Now forms has lost it's dep to WB you can continue porting help to e4 right? How did this effort work out?

Cheers,

Wim
Previous Topic:IEditorPart loses custom icon on detach/move
Next Topic:E4 Command Parameter Object Type
Goto Forum:
  


Current Time: Fri Oct 24 07:46:37 GMT 2014

Powered by FUDForum. Page generated in 0.14329 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software