Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Using P2 to install and uninstall OEPE
Using P2 to install and uninstall OEPE [message #1033869] Thu, 04 April 2013 18:40 Go to next message
s v
Messages: 4
Registered: January 2013
Junior Member
I initially tried installing OEPE using the dropins mechanism, it did not work. "forums.oracle.com/forums/thread.jspa?threadID=2511822&tstart=0"

Then I tried using P2, but ran into issues uninstalling

"forums.oracle.com/forums/thread.jspa?threadID=2511891&tstart=0"

I am trying to find a way to automate the installation and removal of OEPE plugins without bringing up eclipse.

What should I do to properly install/uninstall OEPE using P2?
Re: Using P2 to install and uninstall OEPE [message #1037720 is a reply to message #1033869] Tue, 09 April 2013 23:52 Go to previous messageGo to next message
s v
Messages: 4
Registered: January 2013
Junior Member
installation works fine

eclipsec.exe -application org.eclipse.equinox.p2.director -repository jar:file:oepe-12.1.1.2.1-juno-repository.zip!/ -installIU oracle.eclipse.tools.juno.oepe.product.feature.group -nosplash

but removal has issues

eclipsec.exe -application org.eclipse.equinox.p2.director -uninstallIU oracle.eclipse.tools.juno.oepe.product.feature.group -nosplash


Uninstalling oracle.eclipse.tools.juno.oepe.product.feature.group 2.2.1.201303081427.
Installation failed.
Cannot complete the install because one or more required items could not be found.
Software currently installed: Eclipse IDE for Java EE Developers 1.5.2.20130211-1820 (epp.package.jee 1.5.2.20130211-1820)
Missing requirement: Dali Java Persistence Tools - JPA Support 3.2.2.v201301091616-7U7K8qFC7sRdwVKaof36y4KKI (org.eclipse.jpt.jpa.feature.feature.group 3.2.2.v201301091616-7U7K8qFC7sRdwVKaof36y4KKI)
requires 'org.eclipse.jpt.jpa.gen [2.2.2.v201301082148]' but it could not be found
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.5.2.20130211-1820 (epp.package.jee 1.5.2.20130211-1820)
To: org.eclipse.epp.package.jee.feature.feature.group [1.5.2.20130211-1820]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.5.2.20130211-1820 (org.eclipse.epp.package.jee.feature.feature.group 1.5.2.20130211-1820)
To: org.eclipse.jpt.jpa.feature.feature.group 0.0.0
Application failed, log file location: C:\wls11\eclipse\configuration\1363290121039.log


Any idea why?
Re: Using P2 to install and uninstall OEPE [message #1042755 is a reply to message #1037720] Tue, 16 April 2013 20:51 Go to previous message
s v
Messages: 4
Registered: January 2013
Junior Member
I looked for IU's with org.eclipse.equinox.p2.type.category set to true and picked those IU's in the requires list and I tried the installation

eclipsec.exe -application org.eclipse.equinox.p2.director -repository jar:file:oepe-12.1.1.2.1-juno-repository.zip!/ -installIU oracle.eclipse.tools.juno.adf.doc.v11115.feature.group,oracle.eclipse.tools.juno.weblogic.scripting.feature.group,oracle.eclipse.tools.juno.cloud.feature.group,oracle.eclipse.tools.juno.doc.javaee6.feature.group,oracle.eclipse.tools.juno.adf.doc.v11117.feature.group,oracle.eclipse.tools.juno.database.feature.group,oracle.eclipse.tools.juno.spring.feature.group,oracle.eclipse.tools.juno.adf.doc.v11114.feature.group,oracle.eclipse.tools.juno.weblogic.feature.group,oracle.eclipse.tools.juno.adf.doc.v11116.feature.group,oracle.eclipse.tools.juno.doc.javaee5.feature.group,oracle.eclipse.tools.juno.coherence.feature.group,oracle.eclipse.tools.juno.adf.feature.group,oracle.eclipse.tools.juno.webtier.feature.group,oracle.eclipse.tools.juno.glassfish.feature.group -nosplash

Installation is good; uninstall still fails

eclipsec.exe -application org.eclipse.equinox.p2.director -uninstallIU oracle.eclipse.tools.juno.adf.doc.v11115.feature.group,oracle.eclipse.tools.juno.weblogic.scripting.feature.group,oracle.eclipse.tools.juno.cloud.feature.group,oracle.eclipse.tools.juno.doc.javaee6.feature.group,oracle.eclipse.tools.juno.adf.doc.v11117.feature.group,oracle.eclipse.tools.juno.database.feature.group,oracle.eclipse.tools.juno.spring.feature.group,oracle.eclipse.tools.juno.adf.doc.v11114.feature.group,oracle.eclipse.tools.juno.weblogic.feature.group,oracle.eclipse.tools.juno.adf.doc.v11116.feature.group,oracle.eclipse.tools.juno.doc.javaee5.feature.group,oracle.eclipse.tools.juno.coherence.feature.group,oracle.eclipse.tools.juno.adf.feature.group,oracle.eclipse.tools.juno.webtier.feature.group,oracle.eclipse.tools.juno.glassfish.feature.group -nosplash

still getting the error when I do it with p2 command line. If I do this in the Eclipse GUI no issues

Installation failed.
Cannot complete the install because one or more required items could not be found.
Software currently installed: Eclipse IDE for Java EE Developers 1.5.2.20130211-1820 (epp.package.jee 1.5.2.20130211-1820)
Missing requirement: Dali Java Persistence Tools - JPA Support 3.2.2.v201301091616-7U7K8qFC7sRdwVKaof36y4KKI (org.eclipse.jpt.jpa.feature.feature.group 3.2.2.v201301091616-7U7K8qFC7sRdwVKaof36y4KKI)
requires 'org.eclipse.jpt.jpa.gen [2.2.2.v201301082148]' but it could not be found
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.5.2.20130211-1820 (epp.package.jee 1.5.2.20130211-1820)
To: org.eclipse.epp.package.jee.feature.feature.group [1.5.2.20130211-1820]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.5.2.20130211-1820 (org.eclipse.epp.package.jee.feature.feature.group 1.5.2.20130211-1820)
To: org.eclipse.jpt.jpa.feature.feature.group 0.0.0
Previous Topic:ServiceLoader and OSGi
Next Topic:Do p2 statistics support relative URL?
Goto Forum:
  


Current Time: Thu Oct 30 17:30:02 GMT 2014

Powered by FUDForum. Page generated in 0.03310 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software