Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Testing my RCP app on Eclipse 4.3 - unwanted progress bar is showing
Testing my RCP app on Eclipse 4.3 - unwanted progress bar is showing [message #1033652] Thu, 04 April 2013 13:35 Go to next message
Phil Beauvoir is currently offline Phil Beauvoir
Messages: 22
Registered: October 2012
Junior Member
I'm trying out my e3 based RCP application on Eclipse 4.3 M6.

When launching the application, a progress bar and message is shown on the splash screen even though I have specified that I don't want it visible in a Preference Customization file as referenced in the products extension point preferenceCustomization property:

<extension point="org.eclipse.core.runtime.products" id="product">
<product application="uk.ac.bolton.archimate.editor.app" name="%appName">
<property
name="preferenceCustomization"
value="plugin_customization.ini">
</property>
</product>
</extension>

The "plugin_customization.ini" file contains this line:

org.eclipse.ui/SHOW_PROGRESS_ON_STARTUP = false

And also tried setting it in in the initialize() method of the WorkbenchAdvisor:

PlatformUI.getPreferenceStore().setValue(IWorkbenchPreferenceConstants.SHOW_PROGRESS_ON_STARTUP, false);

This works OK in Eclipe 3.8. Known bug?

[Updated on: Thu, 04 April 2013 15:14]

Report message to a moderator

Re: Testing my RCP app on Eclipse 4.3 - unwanted progress bar is showing [message #1112618 is a reply to message #1033652] Fri, 20 September 2013 00:17 Go to previous messageGo to next message
Kenneth Evans is currently offline Kenneth Evans
Messages: 1
Registered: September 2013
Junior Member
I have the same problem with 4.2.1. I have neither Add a progress bar nor Add a progress message checked. If I do check them, the text color and size do not match what I set.

The color I am getting for the message is white. I can't read it because it is clipped at the bottom. The default color for the text in the Splash tab is black. I have tried red and it remains white. In general, it seems to be ignoring what is set in the Splash tab.
Re: Testing my RCP app on Eclipse 4.3 - unwanted progress bar is showing [message #1115924 is a reply to message #1112618] Tue, 24 September 2013 19:39 Go to previous message
Eric Moffatt is currently offline Eric Moffatt
Messages: 118
Registered: July 2009
Senior Member

Most certainly this is a defect, please open one against Platform->UI.
Previous Topic:Right aligned toolbar in an e4 application
Next Topic:Undocking all parts results in deleting the perspective.
Goto Forum:
  


Current Time: Thu Oct 23 06:04:44 GMT 2014

Powered by FUDForum. Page generated in 0.01749 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software