Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Building BIRT 4.2.x
Building BIRT 4.2.x [message #1033089] Wed, 03 April 2013 21:01
Andrew Aiken is currently offline Andrew AikenFriend
Messages: 4
Registered: March 2013
Junior Member
I'm trying to build BIRT 4.2.2 from the source code, following the instructions here:

I have downloaded the and the Data Tools Platform project. Once I have gotten all the source code I have a number of errors:

  • The project org.eclipse.birt.chart.integration.wtp.ui has 140 errors, a lot of this seems to be missing plug-ins e.g. org.elcipse.jst.j2ee.

  • The project org.eclipse.birt.integration.wtp.ui has 299 errors, this seems to be the same case as the project above.

  • The project has 1 error saying "The type JDBCDriverManager.WrappedDriver must implement the inherited abstract method Driver.getParentLogger()"

  • The project has 1 error saying "The type DriverExt must implement the inherited abstract method Driver.getParentLogger()".

  • The project has 2 errors both saying "Referenced element 'enablement' is not defined".

Even with these errors I can run the report designer, although when I try to create a new report I get a NullPointerException in the DEUtil class at line 3255
URL url = FileLocator.find( Platform.getBundle( IResourceLocator.FRAGMENT_RESOURCE_HOST ),
				new Path( DEFAULT_LIBRARY ),
				null );

Any help in fixing these errors is much appreciated.
Previous Topic:Adding column to Report
Next Topic:to get value from parameter
Goto Forum:

Current Time: Tue Dec 01 22:06:50 GMT 2015

Powered by FUDForum. Page generated in 0.01560 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software