Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP template does not generate BasicEntryPoint
RAP template does not generate BasicEntryPoint [message #1032786] Wed, 03 April 2013 08:35 Go to next message
azrael cat is currently offline azrael cat
Messages: 2
Registered: April 2013
Junior Member
Hello,

in the developer guide there is the code for BasicEntryPoint but I can't find information how to register (in plugin.xml?) it.
The tutorial states unchecking the option "generate activator" but the wizard will always set checked if you go back to the first wizard page. Maybe that is one cause why the class is not created in Eclipse Indigo and Juno.
Could someone please provide information what to do with the tutorials BasicEntryPoint to get it up running manually?

thanks
azrael
Re: RAP template does not generate BasicEntryPoint [message #1033427 is a reply to message #1032786] Thu, 04 April 2013 04:07 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1793
Registered: July 2009
Senior Member
Hi Azrael,
did you install RAP Tools 2.0 [1]? Did you setup RAP Runtime 2.0 as your
active target platform? The RAP templates are working fine with or
without activator. Please give more information how did you setup your
environment, what did you install, did you select "RAP Hello World"
template in the New Project Wizard? I've just checked with Eclipse
Classic 4.2.2 + RAP Tools 2.0 + RAP Runtime 2.0 and everything is
working fine.

[1] http://www.eclipse.org/rap/downloads/
Best,
Ivan

On 4/3/2013 3:38 PM, azrael cat wrote:
> Hello,
>
> in the developer guide there is the code for BasicEntryPoint but I
> can't find information how to register (in plugin.xml?) it.
> The tutorial states unchecking the option "generate activator" but the
> wizard will always set checked if you go back to the first wizard
> page. Maybe that is one cause why the class is not created in Eclipse
> Indigo and Juno.
> Could someone please provide information what to do with the tutorials
> BasicEntryPoint to get it up running manually?
>
> thanks
> azrael

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP template does not generate BasicEntryPoint [message #1033514 is a reply to message #1033427] Thu, 04 April 2013 05:57 Go to previous message
azrael cat is currently offline azrael cat
Messages: 2
Registered: April 2013
Junior Member
Hello Ivan,

I got the wrong version RAP 1.5.
The installation option "download complete IDE package" obviously leads to 1.5 and you have to upgrade manually over update site in option two. Now it works.

Thanks
Azrael
Previous Topic:Applying CSS to RWT without the workbench
Next Topic:Check to see if View is minimized
Goto Forum:
  


Current Time: Wed Aug 20 18:28:31 EDT 2014

Powered by FUDForum. Page generated in 0.01502 seconds