Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Linker Problems(CrossCompiler, Linker)
Linker Problems [message #1032667] Wed, 03 April 2013 05:19 Go to next message
Dusan Markovic is currently offline Dusan Markovic
Messages: 4
Registered: April 2013
Junior Member
Hi@all,

I am using EclipseIDE (Version: Juno Service Release 1) with a cross compiler from "Sourcery CodeBench". In my C test project I need a simple XML parser and so I have downloaded the XML-Library from xmlsoft.org. At the further step I tried to include the XML-Library into my project without success. I get an error at the linking step, cannot find library. All solutions with the affinity to my problem which I found on the net didn't help Crying or Very Sad .

Does anybody know what I make wrong? Any idea what else to try?

Thanks in advance for your help!
Re: Linker Problems [message #1033337 is a reply to message #1032667] Thu, 04 April 2013 02:08 Go to previous messageGo to next message
Axel Mueller is currently offline Axel Mueller
Messages: 1949
Registered: July 2009
Senior Member
http://wiki.eclipse.org/CDT/User/FAQ#Adding_C.2FC.2B.2B_External_Libraries

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: Linker Problems [message #1033353 is a reply to message #1033337] Thu, 04 April 2013 02:37 Go to previous messageGo to next message
Dusan Markovic is currently offline Dusan Markovic
Messages: 4
Registered: April 2013
Junior Member
Hello Axel,

thanks for your answer. I tried these documeted steps before I have posted my problem. It doesn't help and the linker output was the same as described.

Re: Linker Problems [message #1033515 is a reply to message #1033353] Thu, 04 April 2013 06:00 Go to previous messageGo to next message
Axel Mueller is currently offline Axel Mueller
Messages: 1949
Registered: July 2009
Senior Member
You should add the library search path in C/C++ Build" -> "Settings" and then hit the "Libraries" item under "GCC C++ Linker"
The FAQ is not complete, but nobody wants to do this ... Smile


Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: Linker Problems [message #1033753 is a reply to message #1033515] Thu, 04 April 2013 11:48 Go to previous messageGo to next message
Dusan Markovic is currently offline Dusan Markovic
Messages: 4
Registered: April 2013
Junior Member
Hello Axel,

I tried this configuration and now I get the error "undefined reference to ...(used functions from library)". As attachement I sent screen shots of my C/C++ Build configuration.

What I do wrong?

[Updated on: Thu, 04 April 2013 11:49]

Report message to a moderator

Re: Linker Problems [message #1036587 is a reply to message #1032667] Mon, 08 April 2013 11:18 Go to previous message
Dusan Markovic is currently offline Dusan Markovic
Messages: 4
Registered: April 2013
Junior Member
Hello,

has anybody an idea what to do in my case and how to configure eclpise correctly?

THX
Previous Topic:How can i deal with functions with the same name and exist in different .h?
Next Topic:set env.variable based on architecture
Goto Forum:
  


Current Time: Thu Jul 31 17:40:23 EDT 2014

Powered by FUDForum. Page generated in 0.01955 seconds