Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Virgo 3.6.1 and SpringFramework 3.2.2(Using SpringFramework 3.2.2)
Virgo 3.6.1 and SpringFramework 3.2.2 [message #1029193] Fri, 29 March 2013 05:35 Go to next message
Jieke Pan is currently offline Jieke Pan
Messages: 1
Registered: March 2013
Junior Member
Hi all,

I have been trying to use the SpringFramework 3.2.2 in the Virgo Kernel distribution 3.6.1 Release. I have updated the userregion.properties with the following bundles.


- org.springframework.core-3.2.2.RELEASE.jar

- org.springframework.asm-3.1.4.RELEASE.jar

- org.springframework.beans-3.2.2.RELEASE.jar

Virgo was started correctly with no error, but when I checked the bundle list via telnet session, except for the native bundles of Virgo, I could not see any additional bundles above in the list.

I have noticed as well that among the native bundles, there was SpringFramework 3.1.0 installed.

So, my question is, if it was correct to use the version 3.2.2 of Springframework in the Virgo 3.6.1? If so, how?

Thanks.

Pan
29.3.2013


Re: Virgo 3.6.1 and SpringFramework 3.2.2 [message #1037463 is a reply to message #1029193] Tue, 09 April 2013 11:28 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
I'm afraid you need to replace the Spring framework bundles and .libd file wholesale. Please see this FAQ.
Re: Virgo 3.6.1 and SpringFramework 3.2.2 [message #1053634 is a reply to message #1037463] Mon, 06 May 2013 21:38 Go to previous messageGo to next message
Maarten Winkels is currently offline Maarten Winkels
Messages: 11
Registered: May 2013
Junior Member
Hello,

I tried to update the spring version to 3.2.2.RELEASE according to the FAQ (http://wiki.eclipse.org/Virgo/FAQ#How_can_I_change_the_version_of_Spring_framework_in_the_user_region.3F) but to no avail. Vrigo does not start and the log shows

org.osgi.framework.BundleException: The bundle "org.eclipse.virgo.medic_3.6.1.RELEASE [37]" could not be resolved. Reason: Missing Constraint: Import-Package: org.aspectj.lang; version="[1.6.12,2.0.0)"

And then a whole lot of other missing constraints.

I've tried to use AspectJ version 1.7.2 but no luck either.

Any help would be greatly appreciated.

-Maarten Winkels
Re: Virgo 3.6.1 and SpringFramework 3.2.2 [message #1053743 is a reply to message #1053634] Tue, 07 May 2013 09:12 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
I suggest examining Spring framework 3.2.2.RELEASE and seeing what version of org.aspectj.lang it imports. Something made you consider AspectJ 1.7.2, so perhaps you've already done that?
Re: Virgo 3.6.1 and SpringFramework 3.2.2 [message #1053795 is a reply to message #1053743] Tue, 07 May 2013 11:44 Go to previous message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
I took Virgo Server for Apache Tomcat 3.6.1 and upgraded Spring framework to 3.2.2 and AspectJ to 1.7.1 as per the FAQ and it started ok. Did you edit the configuration files as the FAQ tells you to?
Previous Topic:EMF and Virgo
Next Topic:Problem deploying Apache CXF Webservice on Virgo: Cannot resolve XML Schema
Goto Forum:
  


Current Time: Tue Jul 29 16:57:17 EDT 2014

Powered by FUDForum. Page generated in 0.01610 seconds