Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Update to Xtext 2.4 and Xtend 2.4
Update to Xtext 2.4 and Xtend 2.4 [message #1028490] Thu, 28 March 2013 10:16 Go to next message
michael m is currently offline michael m
Messages: 17
Registered: March 2013
Junior Member
Hi

here is some Feedback on the Problems i encountered during migration to 2.4:

1. I had to use XImportSection in import statments.
It links you to the referenced imports out of the box which is pretty nice

2. XbaseScopeProvider is deprecated -> no hint how to replace it
3. Fixed some other issues (non existing methods in xbase and so on)
4. Launched an Eclipse Application and tried to open a dsl file (.dmodel) which lead to the following error:

-> Error: Unresolved proxy .... Make sure the EPackage has been registered.
-> Fix for me: delete both plugin.xml files in my.dsl.model and my.dsl.model.ui
Projects and run MWE2 code generation afterwards (both plugin.xml files are regenerated again and work now)

At this point i can at least open the dsl file.
Generation is still not working correct but thats probably because i fixed the issues in (3) not correct.
Trying to debug is kind of slow. If i step by step through the xtend code there is at least a delay of 10 to 60 sec.

Strange behaviour of Eclipse since i updated:
In my Modelinferrer.xtend file:
ctrl+c and ctrl+p doesn't work after a while
In Edit -> copy and paste is grayed out
Right clicking on the selected text and select copy works
-> it seems that at that point my Xtend files seem out of sync...
If i restart Eclipse i see some pasted text which was not there before

And one last Note:
In my grammar i have the following first line:
grammar my.dsl.Model with org.eclipse.xtext.xbase.Xbase

In 2.3.1 i was able to jump to the Xbase grammar by holding down ctrl + left clicking
on "org.eclipse.xtext.xbase.Xbase". This doesn't work any more in 2.4.0.

These things worked properly with xtext 2.3.1.
I switched back for now because its not useable for me so far.
Hope there will be soon a migration tutorial. Smile
Re: Update to Xtext 2.4 and Xtend 2.4 [message #1029376 is a reply to message #1028490] Fri, 29 March 2013 15:40 Go to previous message
Hallvard Traetteberg is currently offline Hallvard Traetteberg
Messages: 601
Registered: July 2009
Location: Trondheim, Norway
Senior Member
On 28.03.13 08.59, michael b wrote:
>
> 2. XbaseScopeProvider is deprecated -> no hint how to replace it

I noticed this one, too. If you regenerate the abstract runtime modules,
you'll see it's now binding batch scope providers, so you should instead
subclass them, e.g. XBaseBatchScopeProvider.

> Strange behaviour of Eclipse since i updated:
> In my Modelinferrer.xtend file:
> ctrl+c and ctrl+p doesn't work after a while
> In Edit -> copy and paste is grayed out
> Right clicking on the selected text and select copy works

I also experience this, also for other files... I'm not sure this is an
Xtext issue, but it's anyhow annoying.

> -> it seems that at that point my Xtend files seem out of sync...
> If i restart Eclipse i see some pasted text which was not there before

I've seen garbage in Xtend files, which changed the appearance when
moving lines up and down.

> grammar my.dsl.Model with org.eclipse.xtext.xbase.Xbase
>
> In 2.3.1 i was able to jump to the Xbase grammar by holding down ctrl +
> left clicking
> on "org.eclipse.xtext.xbase.Xbase". This doesn't work any more in 2.4.0.

Same for me.

Hallvard
Previous Topic:What is this: " missing EOF at " error?
Next Topic:Escape Hatch
Goto Forum:
  


Current Time: Thu Oct 30 17:39:53 GMT 2014

Powered by FUDForum. Page generated in 0.02043 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software