Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Transport Error - not authorized(Egit refuses to connect with rep)
Transport Error - not authorized [message #1027286] Tue, 26 March 2013 20:18 Go to next message
Karl Morrison is currently offline Karl Morrison
Messages: 1
Registered: March 2013
Junior Member
See file for error message.

I have tried this on two reps now, same error. These reps work for everyone else and my account has full access to both reps.

I have done the following so far with no luck.

• Reinstalled Eclipse
• Deleted .ssh and .eclipse in my users folder "Karl/.eclipse" for example
• Deleted bitbucket folder including all my old reps.
• Window->prefrences->general->network connections-> both SSH2 and cache are clear and in default order

What is causing this annoying error?
  • Attachment: Untitled.png
    (Size: 11.74KB, Downloaded 212 times)
Re: Transport Error - not authorized [message #1033589 is a reply to message #1027286] Thu, 04 April 2013 12:08 Go to previous messageGo to next message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
Are there more details in the error log view (Show View -> Error Log)?

What puzzles me is that given the fact that you want to use https and not ssh, what does it have to do with the .ssh folder?

Which kind of authentication do you use? Can you reset the credentials? (You can do that in the Git Repositories View, Remotes, right click on the Fetch or Push URL, select "Change Credentials" or "Clear Credentials")
Re: Transport Error - not authorized [message #1219756 is a reply to message #1027286] Thu, 05 December 2013 16:19 Go to previous messageGo to next message
VINEET KARKERA is currently offline VINEET KARKERA
Messages: 1
Registered: December 2013
Junior Member
Hi.. I had the exact same problem.

I got it resolved when I deleted the .ssh folder in my /User/Vineet location (although, I don't think this is what fixed it).

Then, on Eclipse, went to Windows -> Preferences -> General -> Network Connections
Changed Active Provider to Manual from the drop down..
then made sure HTTP, HTTPS and SOCKS , localhost and 127.blah.blah was all checked and

Make sure HTTP has a default port of 80, HTTPS default port of 443 and SOCKS default port of 1080. (if not edit it)

-> Click Apply -> Ok

And it is important that you restart Eclipse now.
And Voila it worked. Hope this works for you as well.

Cheers.
Re: Transport Error - not authorized [message #1219846 is a reply to message #1219756] Fri, 06 December 2013 09:13 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 588
Registered: July 2009
Senior Member
EGit 3.2.0 (to be released Dec 18) shows a more comprehensive error message
http://imgur.com/HqGPAwZ
Re: Transport Error - not authorized [message #1219847 is a reply to message #1219846] Fri, 06 December 2013 09:15 Go to previous message
Matthias Sohn is currently offline Matthias Sohn
Messages: 588
Registered: July 2009
Senior Member
this forum software is too dumb to display an image, here the raw link
http://imgur.com/HqGPAwZ
Previous Topic:interactive rebase view
Next Topic:How to enter a new password with Egit?
Goto Forum:
  


Current Time: Fri Oct 24 15:43:30 GMT 2014

Powered by FUDForum. Page generated in 0.01777 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software