Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Headless Product Build(product is not "expanded")
Headless Product Build [message #1027039] Tue, 26 March 2013 13:53 Go to next message
Joaquin Morcate is currently offline Joaquin Morcate
Messages: 49
Registered: March 2010
Member
Hi all,

I an trying to set a headless of a simple RCP. These are the relevant parts of my files

1. build.properties
product= ${env.WORKSPACE}/net.morcate.moviesviewer.releng/moviesviewer.product
......
pde.buildfile=${env.WORKSPACE}/net.morcate.moviesviewer.releng/productBuild.xml

2. build.xml
	<!-- Import enviromental variables -->
	<property environment="env" />
         ....
	<target name="pdebuild" description="Build Eclipse Product">
		<java jar="${eclipse.home}/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar" fork="true" failonerror="true">
			<arg line="-application org.eclipse.ant.core.antRunner " />
			<arg line="-buildfile ${pde.buildfile} " />
			<arg line="-DbuildDirectory=${env.WORKSPACE}/stage  " />
		</java>
	</target>

where WORKSPACE is an environment variable. If I try to build the application I see that the value for "product" is not expanded. If I echo ${product} in the generateFeature target in productBuild.xml I get
 [java] generateFeature:
 [java]      [echo]   
           ${env.WORKSPACE}/net.morcate.moviesviewer.releng/moviesviewer.product 

In the other hand if I enter the real path for the product file in build.properties
product= /home/joaquin/RCP/net.morcate.moviesviewer.releng/moviesviewer.product

everything goes perfect. So the "product" property is visible but not expanded. Any idea why the ${env.WORKSPACE} is not expanded?

Thank you very much.

Joaquin Morcate
Re: Headless Product Build [message #1027629 is a reply to message #1027039] Wed, 27 March 2013 07:43 Go to previous messageGo to next message
Joaquin Morcate is currently offline Joaquin Morcate
Messages: 49
Registered: March 2010
Member
Well the solution is to import the environment also in productBuild.xml. But what I can't understand why the build does not fail when the it tries to open "${env.WORKSPACE}/net.morcate.moviesviewer.releng/moviesviewer.product" that does not exist as it fails if I enter a wrong product file.

Regards

Joaquin Morcate
Re: Headless Product Build [message #1032760 is a reply to message #1027039] Wed, 03 April 2013 12:02 Go to previous messageGo to next message
Mickael Istria is currently offline Mickael Istria
Messages: 765
Registered: July 2009
Location: Grenoble, France
Senior Member
You could also have a look at Tycho to set up headless build. It's
generally way easier.
--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Re: Headless Product Build [message #1035891 is a reply to message #1027039] Sun, 07 April 2013 16:10 Go to previous message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1370
Registered: July 2009
Senior Member
You could have a look at Buckminster to do a headless product build...
here's my tutorial in case

http://www.lorenzobettini.it/2013/01/building-an-eclipse-rcp-product-with-buckminster/

hope this helps
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Previous Topic:Menucontribution only for resources contained in projects with a certain nature
Next Topic:Refactoring with Inline Editing
Goto Forum:
  


Current Time: Sat Oct 25 23:39:34 GMT 2014

Powered by FUDForum. Page generated in 0.08923 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software