Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Trying to install acceleo Ecore to Python module(Getting an error when trying to install the Ecore to Python module.)
Trying to install acceleo Ecore to Python module [message #1024215] Tue, 26 March 2013 01:20 Go to next message
peter cutler is currently offline peter cutler
Messages: 1
Registered: March 2013
Junior Member
Hi,
I downloaded and installed the eclipse modeling tools package.
Eclipse Modeling Tools

Version: Juno Service Release 2
Build id: 20130225-0426

I then went to the acceleo modules update site and tried to install:
Ecore to Python code generator 1.0.0.200902031213

i'm getting a rather odd error when it tries to install:
Cannot complete the install because one or more required items could not be found.
Software currently installed: Ecore to Python code generator 1.0.0.200902031213 (org.acceleo.module.pim.ecore.gen.python_feature.feature.group 1.0.0.200902031213)
Missing requirement: Ecore to Python code generator 1.0.0 (org.acceleo.module.pim.ecore.gen.python 1.0.0) requires 'bundle fr.obeo.acceleo.gen 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Ecore to Python code generator 1.0.0.200902031213 (org.acceleo.module.pim.ecore.gen.python_feature.feature.group 1.0.0.200902031213)
To: org.acceleo.module.pim.ecore.gen.python [1.0.0]

Can anyone tell me where i can find the 0.0.0 gen bundle? or at least get this installed?

thanks
Re: Trying to install acceleo Ecore to Python module [message #1034532 is a reply to message #1024215] Fri, 05 April 2013 14:59 Go to previous messageGo to next message
Stephane Begaudeau is currently offline Stephane Begaudeau
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

The Ecore to Python generator is using Acceleo 2 (fr.obeo.acceleo versus org.eclipse.acceleo) which is not compatible with Acceleo 3.
I don't believe that this generator exists in Acceleo 3 but with the Acceleo 2 source code, you could migrate it in a couple hours.

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau
Google+: +stephane.begaudeau
Blog: http://stephanebegaudeau.tumblr.com | Eclipse Java Development Tools Tips and Tricks



Re: Trying to install acceleo Ecore to Python module [message #1035332 is a reply to message #1034532] Sat, 06 April 2013 18:13 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4086
Registered: July 2009
Senior Member
Hi

For Kepler M6 Ecore to Python is on the Welcome page and appears to be
Acceleo 3.

Regards

Ed Willink

On 05/04/2013 15:59, Stephane Begaudeau wrote:
> Hi,
>
> The Ecore to Python generator is using Acceleo 2 (fr.obeo.acceleo
> versus org.eclipse.acceleo) which is not compatible with Acceleo 3.
> I don't believe that this generator exists in Acceleo 3 but with the
> Acceleo 2 source code, you could migrate it in a couple hours.
>
> Regards,
>
> Stephane Begaudeau, Obeo
>
> --
> Twitter: http://twitter.com/#!/sbegaudeau
> Google+: https://plus.google.com/u/0/105625286543794908607/
> Blog: http://stephanebegaudeau.tumblr.com |
> http://stephanebegaudeau.tumblr.com/post/37318392815/eclipse-java-development-tools
Re: Trying to install acceleo Ecore to Python module [message #1036323 is a reply to message #1035332] Mon, 08 April 2013 08:26 Go to previous messageGo to next message
Stephane Begaudeau is currently offline Stephane Begaudeau
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

Yes you are right, but it is just one of our small examples. We had a more advanced Ecore to Python generator for Acceleo 2. By looking at the error message in the first post, it is this old version that Peter was trying to install.

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau
Google+: +stephane.begaudeau
Blog: http://stephanebegaudeau.tumblr.com | Eclipse Java Development Tools Tips and Tricks



Re: Trying to install acceleo Ecore to Python module [message #1069468 is a reply to message #1034532] Mon, 15 July 2013 23:51 Go to previous message
Daniel Tahin is currently offline Daniel Tahin
Messages: 27
Registered: July 2013
Junior Member
Stephane Begaudeau wrote on Fri, 05 April 2013 10:59
Hi,

The Ecore to Python generator is using Acceleo 2 (fr.obeo.acceleo versus org.eclipse.acceleo) which is not compatible with Acceleo 3.
I don't believe that this generator exists in Acceleo 3 but with the Acceleo 2 source code, you could migrate it in a couple hours.

Regards,

Stephane Begaudeau, Obeo

--



Hello,

i just started to use Acceleo 3.2, and have the same problem. Can you show, how to migrate the 'Ecore to Python generator' to Acceleo 3.2?
(I created a separate topic [Acceleo] Error installing 'Ecore to Python code generator' for Acceleo 3.2)

Thanx a lot,
Daniel
Previous Topic:[Acceleo] Getting started example doesn't work
Next Topic:JET Editor in Kepler
Goto Forum:
  


Current Time: Tue Oct 21 08:56:11 GMT 2014

Powered by FUDForum. Page generated in 0.02179 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software