Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Papyrus install problems. And, what's needed for UML?
Papyrus install problems. And, what's needed for UML? [message #1021628] Wed, 20 March 2013 08:28 Go to next message
Toralf Lund is currently offline Toralf Lund
Messages: 70
Registered: July 2009
Member
Just tried to install "Papyrus Runtime" from
http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/helios
on Eclipse Helios, but it failed with the below message. Any idea what is going on?

I tried "Papyrus all" as well, but with similar results. I did manage to install "Papyrus UML", on the other hand. This also sort of raises a few additional questions, like:


  1. What exactly do I need to install to be able to edit UML diagrams?
  2. Why isn't "Papyrus Runtime" already installed after a successful "Papyrus UML" install? I mean, you'd think that a "runtime" would be a prerequisite for other components, or possibly that the other components would be part of the runtime, but neither seems to be the case here (?)
  3. Does Eclipse component installation always have to be so darn confusing??


Thanks,

- Toralf

(Error output follows.)

An error occurred while collecting items to be installed
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,org.eclipse.epf.common,1.5.0.201101131810.
File has invalid content:/tmp/signatureFile382439104790505828.jar
Invalid content:common.jar
The file "common.jar" in the jar "/tmp/signatureFile382439104790505828.jar" has been tampered!
Problems downloading artifact: osgi.bundle,org.eclipse.epf.common.html,1.5.0.201101131810.
File has invalid content:/tmp/signatureFile5549509020741295656.jar
Invalid content:lib/Tidy.jar
The file "lib/Tidy.jar" in the jar "/tmp/signatureFile5549509020741295656.jar" has been tampered!
Invalid content:commonHTML.jar
The file "commonHTML.jar" in the jar "/tmp/signatureFile5549509020741295656.jar" has been tampered!
Problems downloading artifact: osgi.bundle,org.eclipse.epf.richtext,1.6.0.201101131810.
File has invalid content:/tmp/signatureFile193915286673543073.jar
Invalid content:richtext.jar
The file "richtext.jar" in the jar "/tmp/signatureFile193915286673543073.jar" has been tampered!
Problems downloading artifact: osgi.bundle,org.eclipse.papyrus.diagram.common.palette.customization,0.7.3.v201104270854.
File has invalid content:/tmp/signatureFile4625254506578274974.jar
Invalid content:library.jar
The file "library.jar" in the jar "/tmp/signatureFile4625254506578274974.jar" has been tampered!
Re: Papyrus install problems. And, what's needed for UML? [message #1021632 is a reply to message #1021628] Wed, 20 March 2013 08:35 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
Hi,

I can say that I'm using Papyrus on Eclipse Juno, and the installation has no problems. Can you try to move to Juno?

Just installing Papyrus you can create and edit UML models


good luck!!
Re: Papyrus install problems. And, what's needed for UML? [message #1021677 is a reply to message #1021632] Wed, 20 March 2013 09:55 Go to previous messageGo to next message
Toralf Lund is currently offline Toralf Lund
Messages: 70
Registered: July 2009
Member
Federico Toledo wrote on Wed, 20 March 2013 08:35
Hi,

I can say that I'm using Papyrus on Eclipse Juno, and the installation has no problems. Can you try to move to Juno?

I might, but was rather hoping I wouldn't have to right now, as I seem to spend way too much time on getting everything up and running whenever I switch versions.

Maybe I'm forced to switch, though, to get the features I need, as when I look a bit closer, I notice that the release that works on Helios has rather incomplete UML support. I really wish that Papyrus could be built in a more platform-independent manner:-/ Not sure if it's technically possible, though...

Quote:

Just installing Papyrus you can create and edit UML models


good luck!!


What I was driving at, is that there isn't seems to be one obvious way to "just install Papyrus", since there are at least 3 different "top-level" packages. But maybe that's different with newer releases?
Re: Papyrus install problems. And, what's needed for UML? [message #1021682 is a reply to message #1021677] Wed, 20 March 2013 10:01 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4003
Registered: July 2009
Senior Member
Hi

Yes. It would be great not to have irritating progress such as fire,
wheels and telephones.

Juno gives you UML 2.4.1; enjoy.

Regards

Ed Willink


On 20/03/2013 13:55, Toralf Lund wrote:
> Federico Toledo wrote on Wed, 20 March 2013 08:35
>> Hi,
>>
>> I can say that I'm using Papyrus on Eclipse Juno, and the
>> installation has no problems. Can you try to move to Juno?
>
> I might, but was rather hoping I wouldn't have to right now, as I seem
> to spend way too much time on getting everything up and running
> whenever I switch versions.
>
> Maybe I'm forced to switch, though, to get the features I need, as
> when I look a bit closer, I notice that the release that works on
> Helios has rather incomplete UML support. I really wish that Papyrus
> could be built in a more platform-independent manner:-/ Not sure if
> it's technically possible, though...
>
> Quote:
>> Just installing Papyrus you can create and edit UML models
>>
>>
>> good luck!!
>
>
> What I was driving at, is that there isn't seems to be one obvious way
> to "just install Papyrus", since there are at least 3 different
> "top-level" packages. But maybe that's different with newer releases?
>
Re: Papyrus install problems. And, what's needed for UML? [message #1021685 is a reply to message #1021677] Wed, 20 March 2013 10:09 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
you can also use Papyrus standalone

http://www.papyrusuml.org/scripts/home/publigen/content/templates/show.asp?P=114&L=EN#2
Re: Papyrus install problems. And, what's needed for UML? [message #1021743 is a reply to message #1021685] Wed, 20 March 2013 11:58 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 418
Registered: February 2011
Senior Member
Hi,


Quote:
you can also use Papyrus standalone

http://www.papyrusuml.org/scripts/home/publigen/content/templates/show.asp?P=114&L=EN#2


This is an old, deprecated, unmaintained version, for about 4 years now. So, you *can* use it, but won't get any support for it. Nor any "new" feature.

A litle bit of history:

Papyrusuml (1.12): Before 2009
-- Migrating Papyrus to the Eclipse Foundation --
Papyrus 0.7 (Helios): June 2010
Papyrus 0.8 (Indigo): June 2011
Papyrus 0.9 (Juno): June 2012
Papyrus 0.10 (Kepler): June 2013 - Developer builds only

I really recommend migrating to Juno (Either on Eclipse 3.8 or Eclipse 4.2).


Regards,
Camille
Re: Papyrus install problems. And, what's needed for UML? [message #1022107 is a reply to message #1021682] Thu, 21 March 2013 05:38 Go to previous message
Toralf Lund is currently offline Toralf Lund
Messages: 70
Registered: July 2009
Member
Ed Willink wrote on Wed, 20 March 2013 10:01
Hi

Yes. It would be great not to have irritating progress such as fire,
wheels and telephones.

Yes. With any luck, though, "progress" will soon rid us of silly notions like being able to put improved variants of those wheels on a car without replacing the entire wehicle first...
Quote:

Juno gives you UML 2.4.1; enjoy.

Regards

Ed Willink
On 20/03/2013 13:55, Toralf Lund wrote:
> Federico Toledo wrote on Wed, 20 March 2013 08:35
>> Hi,
>>
>> I can say that I'm using Papyrus on Eclipse Juno, and the
>> installation has no problems. Can you try to move to Juno?
[ ... ]

>

Previous Topic:Rename Controlled Model File Error
Next Topic:Can I use 'self' in sequence diagram?
Goto Forum:
  


Current Time: Fri Jul 25 12:14:54 EDT 2014

Powered by FUDForum. Page generated in 0.02714 seconds