Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » AM3 » Comment installer un AM3 !(PB de XML model)
Comment installer un AM3 ! [message #1020906] Tue, 19 March 2013 02:42 Go to next message
samar sousou is currently offline samar sousou
Messages: 63
Registered: March 2013
Member
Bonjour,
J'ai besoin de votre aide, Au depart j'ai 2 fichiers: un en xsd qui est injecter en .ecore le metamodele et le 2eme est un xml qui presente mon modèle et vu que la transformation atl n'accepte que des .xmi donc il me faut un outil pour resoudre ce probleme. est ce que le AM3 est un bon choix pour l'injection du .xml vers un .xmi et si oui SVP comment je peux l'installer et récupérer a la fin mon .xmi!
Re: Comment installer un AM3 ! [message #1021096 is a reply to message #1020906] Tue, 19 March 2013 10:13 Go to previous messageGo to next message
Guillaume Doux is currently offline Guillaume Doux
Messages: 56
Registered: July 2009
Member
Hello,

The XML injector will not allow you to obtain a model conforming to your xsd->Ecore metamodel, it will only create a model conform to a simple XML metamodel.
If you want to use the XML injector, you will need to write then a transformation from this XML model to your specific metamodel.
If so the XML injector is now available on MoDisco which is part of the Modeling bundle of Eclipse.

Another solution for you would be to look at this post: http://www.eclipse.org/forums/index.php/m/912549/

Best regards,

Guillaume
Re: Comment installer un AM3 ! [message #1021110 is a reply to message #1021096] Tue, 19 March 2013 10:33 Go to previous message
samar sousou is currently offline samar sousou
Messages: 63
Registered: March 2013
Member
Thank you,
finally i obtained my .ecore from the XML injection.
And now what about the transformation from this XML model to my specific metamodel!
I don't know how to implement the XML2MyMetamodel.atl!!!
please have you an exemple that explain how do this transformation.
Previous Topic:example ATL Transformation don't work
Next Topic:[AM3] AM3-Injector "xml to ecore" doesn't work!
Goto Forum:
  


Current Time: Sat Jul 12 14:23:32 EDT 2014

Powered by FUDForum. Page generated in 0.05753 seconds