Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » "Source not Found" in Debug Mode
"Source not Found" in Debug Mode [message #1020670] Mon, 18 March 2013 17:23 Go to next message
John Curry is currently offline John Curry
Messages: 1
Registered: March 2013
Junior Member
Folks,

Program compiles and runs fine but in the Debugger when I use "Step Into", any time the code moves to a different class I get the error "Source Not Found".

My java project is very simple. It consists of two packages that I have written with a few classes in each package. No external jars are called.

I have googled this and tried adding the project to "Edit Source Lookup Path". I've also tried changing the build path to JDK 1.6 rather than JRE 1.6. I've tried a half-dozen more fixes suggested on the internet that I don't really understand.

Anyone any ideas on this. It seems like a very simple thing to try to accomplish but I have spent a dozen hours on it and nothing seems to work including reinstalling Eclipse. Using Juno on VISTA.

Regards,
John.
Re: "Source not Found" in Debug Mode [message #1021217 is a reply to message #1020670] Tue, 19 March 2013 17:18 Go to previous message
David Wegener is currently offline David Wegener
Messages: 1344
Registered: July 2009
Senior Member
Are you getting the Source Not Found on classes you wrote or on Java runtime classes?

If it is your classes, make sure you have debugger related options turned on in the Preferences->Java->Compiler->Classfile Generation section (Check both the workspace and project).

Have you built a jar with your class files in it and added it to your classpath? This can cause the problem as well. You need to make sure that the classes in the jar are built with debug enabled and that there is a source path associated with the jar file.

If the problem is in the Java runtime classes, then you probably haven't associated source with your jdk. You need to make sure that you selected that source be installed with your JDK. There will be a src.zip file in your JDK directory. If you switched from a JRE to a JDK, it is possible that the source didn't get associated. You would then need to associate the src.zip file with all the jars on the Preferences->Java-Installed JREs dialog. Select the JDK and click the edit button. This should open a JRE Definition dialog. Expand the jar files at the bottom of the dialog and use the Source Attachment button to attach the src.zip file.
Previous Topic:Threads in custom Plug-in
Next Topic:How to access to an IResource before it is modified
Goto Forum:
  


Current Time: Fri Oct 24 08:52:35 GMT 2014

Powered by FUDForum. Page generated in 0.07766 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software