Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Running Web App in Juno JEE
Running Web App in Juno JEE [message #1020648] Mon, 18 March 2013 16:25 Go to next message
Graham Seed is currently offline Graham SeedFriend
Messages: 6
Registered: April 2012
Junior Member
Hi

I downloaded and installed the latest version of Eclipse JEE Juno.

I created a new static Web Project and added a index.html to the /WebContent directory.

Then right-clicked the project and selected Run As and selected to run on HTTP Local Preview and got the following runtime exceptions:

Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/jetty/webapp/WebAppContext
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2451)
at java.lang.Class.getMethod0(Class.java:2694)
at java.lang.Class.getMethod(Class.java:1622)
at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
Caused by: java.lang.ClassNotFoundException: org.eclipse.jetty.webapp.WebAppContext
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
... 6 more

Re: Running Web App in Juno JEE [message #1020660 is a reply to message #1020648] Mon, 18 March 2013 16:47 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3245
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/18/2013 10:25 AM, Graham Seed wrote:
> Hi
>
> I downloaded and installed the latest version of Eclipse JEE Juno.
>
> I created a new static Web Project and added a index.html to the
> /WebContent directory.
>
> Then right-clicked the project and selected Run As and selected to run
> on HTTP Local Preview and got the following runtime exceptions:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/eclipse/jetty/webapp/WebAppContext
> at java.lang.Class.getDeclaredMethods0(Native Method)
> at java.lang.Class.privateGetDeclaredMethods(Class.java:2451)
> at java.lang.Class.getMethod0(Class.java:2694)
> at java.lang.Class.getMethod(Class.java:1622)
> at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
> at
> sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
> Caused by: java.lang.ClassNotFoundException:
> org.eclipse.jetty.webapp.WebAppContext
> at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
> at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
> ... 6 more

You should ask this question in the Eclipse web tools platform forum,
not here.
Previous Topic:Eclipse Juno themes
Next Topic:opening Eclipse
Goto Forum:
  


Current Time: Thu Nov 27 05:52:53 GMT 2014

Powered by FUDForum. Page generated in 0.02366 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software