Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Product customization not initialized (using extension)(org.eclipse.core.runtime.products extension defined, but nothing happens)
Product customization not initialized (using extension) [message #1018813] Thu, 14 March 2013 10:17 Go to next message
B Richard
Messages: 6
Registered: March 2013
Junior Member
I'm working on building an Eclipse based IDE, which basically will take the main Eclipse plugins, and add a few of my own. I already developed some plugins, and they're working fine.

I also have a product defining plugin, which have a .product file. In this file, I specified the lauching product extension as "org.eclipse.platform.ide", and the application as "org.eclipse.ui.ide.workbench". I added my dependencies (i.e. my other plugins), and it works great.

However, I wanted to change the default perspective to a custom one I made, so I used the org.eclipse.core.runtime.products extension, and defined some product properties (the usual ones for this extension: preferenceCustomization, aboutText, etc.).

The problem is that those definitions aren't working. I have other extensions defined in this plugin that are working, but anything in the org.eclipse.core.runtime.products extension isn't "loading". The aboutText isn't the one I wrote, the windowsImages aren't the one I chose, the preferenceCustomization aren't the ones from my plugin_customization.ini, etc.

In my .product file, I tried to add the "-perspective myPerspectiveId" property to the configuration file, but this doesn't work either. As a matter of fact, when exporting the product, that property isn't even in the eclipse.ini file. Same goes when I tried to add the "-preferenceCustomization" property.

So I'm obviously doing something wrong, but I have no idea what. Anyone knows?

Thanks.
Re: Product customization not initialized (using extension) [message #1019386 is a reply to message #1018813] Fri, 15 March 2013 11:25 Go to previous message
B Richard
Messages: 6
Registered: March 2013
Junior Member
It seems that it's an Eclipse 4 bug, preventing the use of preferenceCustomization, as discussed here.
Previous Topic:Eclipse plugin for flow diagram
Next Topic:editor and view dependency
Goto Forum:
  


Current Time: Thu Apr 17 11:43:53 EDT 2014

Powered by FUDForum. Page generated in 0.02558 seconds