Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » stable dev build 0.9.6.20080811-2209 is published
stable dev build 0.9.6.20080811-2209 is published [message #13830] Tue, 12 August 2008 01:05 Go to next message
Eugene Kuleshov is currently offline Eugene Kuleshov
Messages: 505
Registered: July 2009
Senior Member
We have published stable development build 0.9.6.20080811-2209, which
can be installed from the dev update site at
http://m2eclipse.sonatype.org/update-dev/

This build includes several bug fixes for the Form-based POM editor.
See list of fixed issues in JIRA at http://tinyurl.com/6rhdwr

The most notable new feature is the content assist in POM XML editor
for elements inside plugin's <configuration>.

New action "Show Dependency Hierarchy" is added to the Maven popup
menu on "Maven Dependencies" container entries. It can be used to open
selected dependency in the "Dependency Hierarchy" viewer.

You can see complete New and Noteworthy features for this and
previous builds on the wiki at
http://docs.codehaus.org/display/M2ECLIPSE/New+and+Noteworth y

As always, please don't hesitate to share your thoughts in the news
group and mailing lists, submit bug reports to the project issue tracker
[1] and contribute to project documentation on the wiki [2].

Thanks

m2eclipse team

[1] http://jira.codehaus.org/browse/MNGECLIPSE
[2] http://docs.codehaus.org/display/M2ECLIPSE
Re: stable dev build 0.9.6.20080811-2209 is published [message #15158 is a reply to message #13830] Wed, 13 August 2008 01:38 Go to previous messageGo to next message
Eclipse User
Originally posted by: David.Barri.macquarie.com

Hi,

I'm trying to update from the previous dev build but I'm getting this
error.
I don't know if its a problem with the update site or my Eclipse. Any
ideas?


!ENTRY org.eclipse.equinox.p2.engine 4 4 2008-08-13 15:37:31.065
!MESSAGE An error occurred while collecting items to be installed
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.components.maven_model_edit/osgi.bundle/1.0.0. 20080811-2208
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse/osgi.bundle/0.9.6.20080811-2209
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.book/osgi.bundle/0.9.6.20080811-2210
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.book.feature/org.eclipse.update.featur e/0.9.6.20080811-2210
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.editor.xml/osgi.bundle/0.9.6.20080811- 2210
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.editor.xml.feature/org.eclipse.update. feature/0.9.6.20080811-2210
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.feature/org.eclipse.update.feature/0.9 .6.20080811-2210
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.editor/osgi.bundle/0.9.6.20080811-2210
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.editor.feature/org.eclipse.update.feat ure/0.9.6.20080811-2210
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
15:37:31.065
!MESSAGE No repository found containing:
org.maven.ide.eclipse.jdt/osgi.bundle/0.9.6.20080811-2209

Thanks,
David
Re: stable dev build 0.9.6.20080811-2209 is published [message #15185 is a reply to message #15158] Wed, 13 August 2008 07:31 Go to previous messageGo to next message
Eclipse User
Originally posted by: igor.ifedorenko.com

David,

This looks like Eclipse is not able to read all metadata from m2e update
site. Does your network have http proxy by any chance?

David Barri wrote:
> Hi,
>
> I'm trying to update from the previous dev build but I'm getting this
> error.
> I don't know if its a problem with the update site or my Eclipse. Any
> ideas?
>
>
> !ENTRY org.eclipse.equinox.p2.engine 4 4 2008-08-13 15:37:31.065
> !MESSAGE An error occurred while collecting items to be installed
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.components.maven_model_edit/osgi.bundle/1.0.0. 20080811-2208
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse/osgi.bundle/0.9.6.20080811-2209
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.book/osgi.bundle/0.9.6.20080811-2210
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.book.feature/org.eclipse.update.featur e/0.9.6.20080811-2210
>
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.editor.xml/osgi.bundle/0.9.6.20080811- 2210
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.editor.xml.feature/org.eclipse.update. feature/0.9.6.20080811-2210
>
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.feature/org.eclipse.update.feature/0.9 .6.20080811-2210
>
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.editor/osgi.bundle/0.9.6.20080811-2210
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.editor.feature/org.eclipse.update.feat ure/0.9.6.20080811-2210
>
> !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2008-08-13
> 15:37:31.065
> !MESSAGE No repository found containing:
> org.maven.ide.eclipse.jdt/osgi.bundle/0.9.6.20080811-2209
>
> Thanks,
> David
>
Re: stable dev build 0.9.6.20080811-2209 is published [message #17205 is a reply to message #15185] Tue, 07 October 2008 14:36 Go to previous messageGo to next message
Nick Maiorana is currently offline Nick Maiorana
Messages: 2
Registered: July 2009
Junior Member
I am having the same issue. I have tried on two different computers one
with and one w/out proxy and they both fail.
Re: stable dev build 0.9.6.20080811-2209 is published [message #17233 is a reply to message #17205] Tue, 07 October 2008 14:46 Go to previous message
Nick Maiorana is currently offline Nick Maiorana
Messages: 2
Registered: July 2009
Junior Member
I solved this issue by removing the update site and putting it back in
again. Go figure...
Previous Topic:eclipse red error circles in profiles.xml
Next Topic:Tycho build 0.3.0-DEV-1671
Goto Forum:
  


Current Time: Sat Aug 30 16:38:22 EDT 2014

Powered by FUDForum. Page generated in 0.02488 seconds