Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Installing boost with eclipse
Installing boost with eclipse [message #1017103] Sat, 09 March 2013 10:03 Go to next message
Bersac Guillaume is currently offline Bersac Guillaume
Messages: 7
Registered: March 2013
Junior Member
Hi,

I a trying to use eclipse as a IDE for a project with Boost. I tryed the instructions here : theseekersquill.files.wordpress.com/2010/08/eclipseboostincludepath.png
but I can't succed to compile.
First I haven't been able to instal the MinGW Compiler Toolchain (in the Wascana repository URL). It seems like it is no longer supported.
Then I typed this text in my project :

#include <boost/lambda/lambda.hpp>
#include <iostream>
#include <iterator>
#include <algorithm>

int main()
{
	using namespace boost::lambda;
    typedef std::istream_iterator<int> in;

    std::for_each(
        in(std::cin), in(), std::cout << (_1 * 3) << " " );
}


I have this errors :
cannot open output file test_boost.exe: Permission denied
Symbol 'lambda' could not be resolved


Can you explain me why it is not working ?

[Updated on: Sat, 09 March 2013 10:08]

Report message to a moderator

Re: Installing boost with eclipse [message #1017144 is a reply to message #1017103] Sat, 09 March 2013 21:02 Go to previous messageGo to next message
Klaus Mr is currently offline Klaus Mr
Messages: 117
Registered: November 2011
Senior Member
Hello,

Wascana is outdated and is no longer supported.

You should remove Wascana and use the installer (Gui-Version) to install an up-to-date version of MinGW:
http://sourceforge.net/projects/mingw/files/Installer/mingw-get-inst/

And add the Path to the compiler to the environment variable "Path". See my other message in this forum.

I cannot help you with your Boost issue, because I have no Boost know how. But maybe the update to the new compiler helps.


regards,
Klaus


Re: Installing boost with eclipse [message #1017160 is a reply to message #1017144] Sun, 10 March 2013 08:32 Go to previous messageGo to next message
Bersac Guillaume is currently offline Bersac Guillaume
Messages: 7
Registered: March 2013
Junior Member
Thanks

I have already installed MinGW. This is still not working. I included my boost/include folder and now, when I use completion within a #include "", eclipse suggest boost/lambda/lambda.hpp, and I can find this file in the include folder of my project. But when I compile, it is like my compiler can't find the way to this file. Why ?

By the way, what is the difference between adding include path in : Project properties/ C/C++ Build / Settings / Tool Settings / GCC C++ compiler / Includes / Include Path (-I) (this is where I set my includes folders) and : Project properties/ C/C++ General / Path and Symbols / Includes / Languages [Assembly || GNU C || GNU C++] / Includes directories ?

Another question : if I create a makefile project, does it make the completion less powerful ?

[Updated on: Sun, 10 March 2013 12:59]

Report message to a moderator

Re: Installing boost with eclipse [message #1019504 is a reply to message #1017160] Fri, 15 March 2013 21:16 Go to previous message
Richard Daehler-Wilking is currently offline Richard Daehler-Wilking
Messages: 1
Registered: February 2013
Junior Member
I am having the same problem in 64-bit Win 7 trying to compile the first simple Boost tutorial exercise, which uses [#include <boost/lambda/lambda.hpp>]. It is unable to accept the main Boost directory as an #include <...> starting point. I have seen some posts explaining that Eclipse must be told where to find the include directories, and I have populated the project's [Properties > C/C++ Build > Settings > Tool Settings > GCC C++ Compiler > Includes] entries for both [Include paths (-I)] and [Include files (-include)] with various combinations like ["C:/Program Files/Boost_1_53_0"] (with quotes), [C:/Program Files/Boost_1_53_0] (without quotes), ["C:\\Program Files\\Boost_1_53_0"] (quotes with double backslashes), [C:\\Program Files\\Boost_1_53_0] (no quotes, with double backslashes).

I have also populated [C/C++ General > Paths and Symbols > Includes > GNU C++ with [C:/Program Files/Boost_1_53_0], both with and without quotes. In particular, I've tried it with the same formatting used for the MinGW directories that seem to cause it no problems.

With the -v setting for verbose output, it reports that it's ignoring various duplicate MinGW directories, but does NOT show my Boost directories under either [#include "..." search starts here:] or [#include <...> search starts here:].
Previous Topic:Indent with tabs do not work
Next Topic:Eclipse Juno CDT Error in final launch sequence
Goto Forum:
  


Current Time: Fri Oct 31 12:26:41 GMT 2014

Powered by FUDForum. Page generated in 0.18141 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software