Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » deployed war reports 404 but works in IDE
deployed war reports 404 but works in IDE [message #1016986] Fri, 08 March 2013 08:36 Go to next message
Erdal Karaca is currently offline Erdal Karaca
Messages: 736
Registered: July 2009
Senior Member
What could I miss/check if the rap app works when running from the IDE but reports a "404 not found" once deployed in tomcat 7?
Re: deployed war reports 404 but works in IDE [message #1016994 is a reply to message #1016986] Fri, 08 March 2013 09:05 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1794
Registered: July 2009
Senior Member
Hi,
I hope that this FAQ entry will help you to troubleshoot your deployment
problems:
http://wiki.eclipse.org/RAP/FAQ#Exported_WAR_file_does_not_work
Best,
Ivan

On 3/8/2013 3:36 PM, Erdal Karaca wrote:
> What could I miss/check if the rap app works when running from the IDE
> but reports a "404 not found" once deployed in tomcat 7?

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: deployed war reports 404 but works in IDE [message #1018675 is a reply to message #1016994] Thu, 14 March 2013 05:42 Go to previous messageGo to next message
Erdal Karaca is currently offline Erdal Karaca
Messages: 736
Registered: July 2009
Senior Member
Hi Ivan,
I started with the provided test war "rapdemo.war" which has the same error.
Is Tomcat 7.0.37 (on a WinXP virtual machine) supposed to work with the latest RAP?

Thanks!

Ivan Furnadjiev wrote on Fri, 08 March 2013 15:05
Hi,
I hope that this FAQ entry will help you to troubleshoot your deployment
problems:
http://wiki.eclipse.org/RAP/FAQ#Exported_WAR_file_does_not_work
Best,
Ivan

On 3/8/2013 3:36 PM, Erdal Karaca wrote:
> What could I miss/check if the rap app works when running from the IDE
> but reports a "404 not found" once deployed in tomcat 7?

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/

Re: deployed war reports 404 but works in IDE [message #1018706 is a reply to message #1018675] Thu, 14 March 2013 06:35 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf Sternberg
Messages: 1290
Registered: July 2009
Senior Member

Hi Erdal,

what is the URL of your application? In a WAR deployment, you usually
have to add a context path like

host:port/rapdemo/controls

whereas you can access the application without a context path when
launching from the IDE, such as

host:port/controls

Does that help?
Ralf

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: deployed war reports 404 but works in IDE [message #1022236 is a reply to message #1018706] Thu, 21 March 2013 10:19 Go to previous message
Erdal Karaca is currently offline Erdal Karaca
Messages: 736
Registered: July 2009
Senior Member
Thanks, Ralf, that was it!
I also removed the jetty plugins and the servletbridge plugin which were automatically added by the WAR Product wizard.

Ralf Sternberg wrote on Thu, 14 March 2013 11:35
Hi Erdal,

what is the URL of your application? In a WAR deployment, you usually
have to add a context path like

host:port/rapdemo/controls

whereas you can access the application without a context path when
launching from the IDE, such as

host:port/controls

Does that help?
Ralf

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/

Previous Topic:Eclipse RAP editor
Next Topic:determine whether the RAP application is running from the IDE or from a JEE container
Goto Forum:
  


Current Time: Sat Aug 23 15:16:46 EDT 2014

Powered by FUDForum. Page generated in 0.11072 seconds