Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Missing requirement when exporting product
Missing requirement when exporting product [message #1016741] Thu, 07 March 2013 14:15 Go to next message
tony hedoux is currently offline tony hedoux
Messages: 19
Registered: May 2012
Junior Member
Hi,

I try to export as product a feature's based project, but i have an issue i can't figure out :

Missing requirement: Apache Commons JSP 2.0 Expression Language Interpreter 1.0.0.v201101211617 (org.apache.commons.el 1.0.0.v201101211617) requires 'package javax.servlet.jsp [2.0.0,2.1.0)' but it could not be found

When I look at my Target platform, i can see that required plugins (org.apache.commons.el, javax.servlet.jsp) are here, with correct versions (see attached files).

I don't understand why export product can't resolve this dependency. On the way, when i build my product with TychoMaven, I have not this issue.

Any idea?

Thx for help

Tony



Re: Missing requirement when exporting product [message #1017140 is a reply to message #1016741] Sat, 09 March 2013 20:29 Go to previous message
chai maa is currently offline chai maa
Messages: 8
Registered: February 2012
Junior Member
Hello Tony,
Can you also post the manifest.mf file, that would give a much better idea.

Regards,
Chaitannya
Previous Topic:Hide a parent folder but show its children in cnf view [Common Navigator]
Next Topic:XML: No embedded stylesheet instruction for file:
Goto Forum:
  


Current Time: Sat Oct 25 20:00:45 GMT 2014

Powered by FUDForum. Page generated in 0.01669 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software