Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » XMIIDs recreated in atl2006 compiler(Why do the IDs get regenerated)
XMIIDs recreated in atl2006 compiler [message #1016259] Tue, 05 March 2013 17:06 Go to next message
Ronan B is currently offline Ronan BFriend
Messages: 249
Registered: July 2009
Senior Member
Hi,
I'm using the UML2Copy from http://soft.vub.ac.be/viewvc/UML2CaseStudies/uml2cs-transformations/transformations/UML2Copy.atl?revision=8703&view=markup. However, when using a version that uses the atl2006 compiler the xmiids are always recreated. Is it possible to copy the xmiids with the atl2006 compiler? I've even tried it with a simple piece of ATL like the following and it doesn't copy the IDs.

rule Model {
from s : UML2!"uml::Model" in IN
to t : UML2!"uml::Model" (
__xmiID__ <- s.__xmiID__,
name <- s.name
)
}

I have seen the latest UML2Copy that uses the emftvm compiler works fine. However, we don't want to use this compiler just yet as the launchers are quite different from the existing API.

Any ideas?

Thanks!
Ronan
Re: XMIIDs recreated in atl2006 compiler [message #1025048 is a reply to message #1016259] Tue, 26 March 2013 10:00 Go to previous messageGo to next message
Ronan B is currently offline Ronan BFriend
Messages: 249
Registered: July 2009
Senior Member
Bug now filed at https://bugs.eclipse.org/bugs/show_bug.cgi?id=404344
Previous Topic:Microsoft Office Excel Injector does not produce output
Next Topic:XML2metamodel exemple
Goto Forum:
  


Current Time: Sun Dec 21 06:52:38 GMT 2014

Powered by FUDForum. Page generated in 0.13492 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software