Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Update BIRT 4.2.1 to BIRT 4.2.2 / Eclipse Juno: Conflicting dependency
Update BIRT 4.2.1 to BIRT 4.2.2 / Eclipse Juno: Conflicting dependency [message #1016014] Mon, 04 March 2013 10:33 Go to next message
Jakob Altenstein is currently offline Jakob Altenstein
Messages: 19
Registered: February 2013
Junior Member
Hi,

I just wanted to update my Eclipse / BIRT to the latest version of BIRT, 4.2.2, coming from 4.2.1.
When using the "Check for updates" functionality, I get the message that there is a conflicting dependency. How do I solve the problem? I really would love to update because in 4.2.2 there seems to be an SVG tooltip problem solved which affected my charts badly...

Cannot complete the install because of a conflicting dependency.
  Software being installed: BIRT Engine OSGi Runtime SDK Feature 4.2.2.v201210101433-793387uDbEqKCURUlhLXMF7z0yw8 (org.eclipse.birt.osgi.runtime.sdk.feature.group 4.2.2.v201210101433-793387uDbEqKCURUlhLXMF7z0yw8)
  Software currently installed: BIRT Chart Framework 4.2.1.v20120820-828i7EFQCnvK_6wFGvqLR (org.eclipse.birt.chart.feature.group 4.2.1.v20120820-828i7EFQCnvK_6wFGvqLR)
  Only one of the following can be installed at once: 
    BIRT Chart Device SVG Extension 4.2.2.v201212171413 (org.eclipse.birt.chart.device.svg 4.2.2.v201212171413)
    BIRT Chart Device SVG Extension 4.2.0.v20120611 (org.eclipse.birt.chart.device.svg 4.2.0.v20120611)
    BIRT Chart Device SVG Extension 4.2.1.v20120820 (org.eclipse.birt.chart.device.svg 4.2.1.v20120820)
  Cannot satisfy dependency:
    From: BIRT Chart Framework 4.2.1.v20120820-828i7EFQCnvK_6wFGvqLR (org.eclipse.birt.chart.feature.group 4.2.1.v20120820-828i7EFQCnvK_6wFGvqLR)
    To: org.eclipse.birt.chart.device.svg [4.2.1.v20120820]
  Cannot satisfy dependency:
    From: BIRT Engine OSGi Runtime Feature 4.2.2.v201301281649-ApAY8nG7JNLeWJJW1Zp8d (org.eclipse.birt.osgi.runtime.feature.group 4.2.2.v201301281649-ApAY8nG7JNLeWJJW1Zp8d)
    To: org.eclipse.birt.chart.device.svg [4.2.2.v201212171413]
  Cannot satisfy dependency:
    From: BIRT Engine OSGi Runtime SDK Feature 4.2.2.v201210101433-793387uDbEqKCURUlhLXMF7z0yw8 (org.eclipse.birt.osgi.runtime.sdk.feature.group 4.2.2.v201210101433-793387uDbEqKCURUlhLXMF7z0yw8)
    To: org.eclipse.birt.osgi.runtime.feature.group [4.2.2.v201301281649-ApAY8nG7JNLeWJJW1Zp8d]


I don't really know how to interpret the error message / conflicting dependency message. So any help is appreciated to solve the issue. Please let me know if you need more information!

My specs:
Eclipse: Eclipse Java EE IDE for Web Developers., Version: Juno Service Release 1, Build id: 20121004-1855
BIRT: BIRT 4.2.1, previously downloaded via "Install new software" and server http://download.eclipse.org/birt/update-site/4.2
java -version: Java 1.7.0_09 Java (TM) SE Runtime Environment (build 1.7.0_09-b05), Java HotSpot (TM) 64 Bit Server VM (build 23.5-b02, mixed mode)
javac -version: javac 1.7.0_09
Re: Update BIRT 4.2.1 to BIRT 4.2.2 / Eclipse Juno: Conflicting dependency [message #1016034 is a reply to message #1016014] Mon, 04 March 2013 11:32 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Jakob

I just tried updating my 4.2.1 instance to 4.2.2 using the check for updates menu item and it worked fine for me. BTW I also looked that the SVG tool tip issue and it appears to be fixed.
Your issue looks like you have a couple versions of birt that are active. Can you restart with a -clean? Also you could try to download the allinone build in a separate install directory.

Jason
Re: Update BIRT 4.2.1 to BIRT 4.2.2 / Eclipse Juno: Conflicting dependency [message #1016083 is a reply to message #1016034] Mon, 04 March 2013 16:42 Go to previous messageGo to next message
Byron Palmer is currently offline Byron Palmer
Messages: 11
Registered: July 2009
Junior Member
I also have this problem. I tried starting with a -clean with no luck. I looked at what was installed and I do not have multiple versions installed based on the directories. This may depend on when you updated and how new the version you are using is. Maybe Eclipse has a problem with upgrades over time? It has been a problem in the past but seems to be better recently, until this one came along. I realize that dependency management is difficult but this problem needs to be fixed.

Thanks
Re: Update BIRT 4.2.1 to BIRT 4.2.2 / Eclipse Juno: Conflicting dependency [message #1016306 is a reply to message #1016083] Tue, 05 March 2013 18:47 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Byron

Where you upgrading an existing version of the EPP Reporting package?

Jason
Previous Topic:Reports Run Multiple Times
Next Topic:Using Birt perspective in own RCP
Goto Forum:
  


Current Time: Thu Aug 21 02:20:46 EDT 2014

Powered by FUDForum. Page generated in 0.01648 seconds