Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » e4 and 4.2.2?
icon5.gif  e4 and 4.2.2? [message #1015744] Sat, 02 March 2013 02:56
Craig Foote is currently offline Craig Foote
Messages: 195
Registered: July 2009
Senior Member
I tried http://www.vogella.com/updatesite/e4tools with 4.2.2 and got:
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.12.0.v20130214-0917 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.12.0.v20130214-0917)
  Software currently installed: Eclipse SDK 4.2.2.M20130204-1200 (org.eclipse.sdk.ide 4.2.2.M20130204-1200)
  Only one of the following can be installed at once: 
    Eclipse UI Application Services 0.10.1.v20120523-1955 (org.eclipse.e4.ui.services 0.10.1.v20120523-1955)
    Eclipse UI Application Services 0.10.2.v20120726-172631 (org.eclipse.e4.ui.services 0.10.2.v20120726-172631)
    Eclipse UI Application Services 0.10.2.v20121129-151235 (org.eclipse.e4.ui.services 0.10.2.v20121129-151235)
    Eclipse UI Application Services 0.10.3.v20130123-162658 (org.eclipse.e4.ui.services 0.10.3.v20130123-162658)
    Eclipse UI Application Services 0.10.2.v20121113-130749 (org.eclipse.e4.ui.services 0.10.2.v20121113-130749)
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS (org.eclipse.e4.rcp.feature.group 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS)
    To: org.eclipse.e4.ui.services [0.10.3.v20130123-162658]
  Cannot satisfy dependency:
    From: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.12.0.v20130214-0917 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.12.0.v20130214-0917)
    To: org.eclipse.e4.ui.services [0.10.2.v20120726-172631]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7 (org.eclipse.platform.feature.group 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7)
    To: org.eclipse.rcp.feature.group [4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h (org.eclipse.rcp.feature.group 4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h)
    To: org.eclipse.e4.rcp.feature.grohttp://download.eclipse.org/e4/downloads/drops/R-0.12-201206131100/repositoryup [1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5 (org.eclipse.sdk.feature.group 4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5)
    To: org.eclipse.platform.feature.group [4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7]
  Cannot satisfy dependency:
    From: Eclipse SDK 4.2.2.M20130204-1200 (org.eclipse.sdk.ide 4.2.2.M20130204-1200)
    To: org.eclipse.sdk.feature.group [4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5]


I tried http://download.eclipse.org/e4/downloads/drops/R-0.12-201206131100/repository and got:
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.12.0.v20120529-2033-7E9-5FIhIexRlw7xUB2_U (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.12.0.v20120529-2033-7E9-5FIhIexRlw7xUB2_U)
  Software currently installed: Eclipse SDK 4.2.2.M20130204-1200 (org.eclipse.sdk.ide 4.2.2.M20130204-1200)
  Only one of the following can be installed at once: 
    Eclipse CSS SWT Support 0.10.2.v20120821-165957 (org.eclipse.e4.ui.css.swt 0.10.2.v20120821-165957)
    Eclipse CSS SWT Support 0.10.1.v20120523-1955 (org.eclipse.e4.ui.css.swt 0.10.1.v20120523-1955)
    Eclipse CSS SWT Support 0.10.3.v20130123-162658 (org.eclipse.e4.ui.css.swt 0.10.3.v20130123-162658)
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS (org.eclipse.e4.rcp.feature.group 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS)
    To: org.eclipse.e4.ui.css.swt [0.10.3.v20130123-162658]
  Cannot satisfy dependency:
    From: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.12.0.v20120529-2033-7E9-5FIhIexRlw7xUB2_U (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.12.0.v20120529-2033-7E9-5FIhIexRlw7xUB2_U)
    To: org.eclipse.e4.ui.css.swt [0.10.1.v20120523-1955]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7 (org.eclipse.platform.feature.group 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7)
    To: org.eclipse.rcp.feature.group [4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h (org.eclipse.rcp.feature.group 4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h)
    To: org.eclipse.e4.rcp.feature.group [1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5 (org.eclipse.sdk.feature.group 4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5)
    To: org.eclipse.platform.feature.group [4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7]
  Cannot satisfy dependency:
    From: Eclipse SDK 4.2.2.M20130204-1200 (org.eclipse.sdk.ide 4.2.2.M20130204-1200)
    To: org.eclipse.sdk.feature.group [4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5]


I tried http://download.eclipse.org/e4/downloads/drops/I20130228-2200/repository and got:
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.12.0.v20130221-1605 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.12.0.v20130221-1605)
  Software currently installed: Eclipse SDK 4.2.2.M20130204-1200 (org.eclipse.sdk.ide 4.2.2.M20130204-1200)
  Only one of the following can be installed at once: 
    Eclipse Dependency Injection Extensions 0.11.0.v20120523-2004 (org.eclipse.e4.core.di.extensions 0.11.0.v20120523-2004)
    Eclipse Dependency Injection Extensions 0.11.100.v20121024-182359 (org.eclipse.e4.core.di.extensions 0.11.100.v20121024-182359)
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS (org.eclipse.e4.rcp.feature.group 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS)
    To: org.eclipse.e4.core.di.extensions [0.11.100.v20121024-182359]
  Cannot satisfy dependency:
    From: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.12.0.v20130221-1605 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.12.0.v20130221-1605)
    To: org.eclipse.e4.core.di.extensions [0.11.0.v20120523-2004]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7 (org.eclipse.platform.feature.group 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7)
    To: org.eclipse.rcp.feature.group [4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h (org.eclipse.rcp.feature.group 4.2.2.v20130129-152330-7IARAABrMQkGSvMgQnUlz-DQz00h)
    To: org.eclipse.e4.rcp.feature.group [1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5 (org.eclipse.sdk.feature.group 4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5)
    To: org.eclipse.platform.feature.group [4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7]
  Cannot satisfy dependency:
    From: Eclipse SDK 4.2.2.M20130204-1200 (org.eclipse.sdk.ide 4.2.2.M20130204-1200)
    To: org.eclipse.sdk.feature.group [4.2.2.v20130116-114742-7T7oDVDQ23Iosz-vkFwNncmx7z-9Rts4b0m1FotkYacO5]


Any ideas?

Also, I think I must be missing the point somewhere but why do I need to install e4 tooling independently? Wouldn't the best way to encourage adoption of e4 development
be to distribute the e4 tooling in an official distribution, perhaps the RCP one? It seems to me that there's always a period of broken e4 functionality with each eclipse release. I understand the whole incubator thing but isn't the modelled workbench, DI, etc. mature yet?

2 cents,
Craig
Previous Topic:JRE is not being bundled
Next Topic:Core expressions in compatibility mode
Goto Forum:
  


Current Time: Fri Oct 31 09:54:37 GMT 2014

Powered by FUDForum. Page generated in 0.02002 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software