Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Reset perspective though command for perspective created by application model not showing any part i(Reset perspective though command for perspective created by application model not showing any part i)
Reset perspective though command for perspective created by application model not showing any part i [message #1015546] Fri, 01 March 2013 03:38 Go to next message
sumit singh is currently offline sumit singh
Messages: 129
Registered: October 2012
Location: Bangalore
Senior Member

Create RCP in eclipse juno .

Create a perspective using Application.e4xmi, add part stack and part.
And menu resetPerspective using org.eclipse.ui.window.resetPerspective command.

application runs perfect, but if you reset perspective then every think gone.

In JavaScript perspective in same RCP its work fine.

Application before reset.

index.php/fa/13624/0/

Application after Perspective

index.php/fa/13625/0/

Apllication.e4.xmi for above perspective

index.php/fa/13626/0/
Re: Reset perspective though command for perspective created by application model not showing any pa [message #1015580 is a reply to message #1015546] Fri, 01 March 2013 04:29 Go to previous message
Sopot Cela is currently offline Sopot Cela
Messages: 596
Registered: December 2010
Senior Member

Is this a e4 with compatibility layer app? Is there anything weird in the log ?
Previous Topic:Properties view (compatibility view)
Next Topic:Control over close button on Part tab
Goto Forum:
  


Current Time: Sat Jul 26 09:10:24 EDT 2014

Powered by FUDForum. Page generated in 0.01842 seconds