Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » [EGL] Error when adding Enumeration Classes to the Model
[EGL] Error when adding Enumeration Classes to the Model [message #1015378] Thu, 28 February 2013 12:31 Go to next message
Patricia Fernández is currently offline Patricia Fernández
Messages: 41
Registered: October 2012
Member
Hello,

I'm creating few .egl templates and everything was fine until I included Enumeration Classes to the UML model. Now if I run my main template (ProjectCreation.egl) it gives me an error but if I run it again, it works perfectly. Minimal attached.
  • Attachment: Minimal.zip
    (Size: 10.46KB, Downloaded 30 times)

[Updated on: Thu, 28 February 2013 12:32]

Report message to a moderator

Re: [EGL] Error when adding Enumeration Classes to the Model [message #1015509 is a reply to message #1015378] Fri, 01 March 2013 00:38 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 887
Registered: July 2009
Senior Member
Hi Patricia,

The provided model (Pruebas.uml) makes use of several profiles which do not appear to be included in the zipped project. Could you perhaps provide a trimmed down version of the model that doesn't use these profiles and which validates without problems in the tree-based editor (right-click -> Validate)?

Cheers,
Dimitris
Re: [EGL] Error when adding Enumeration Classes to the Model [message #1015632 is a reply to message #1015509] Fri, 01 March 2013 13:16 Go to previous messageGo to next message
Patricia Fernández is currently offline Patricia Fernández
Messages: 41
Registered: October 2012
Member
Hi Dimitris,

Those profiles are generated automatically when I export the UML model using MagicDraw so I cannot delete them, I've added all of them to the Model folder and checked that it validates. Hope it helps.

Thanks in advance.
  • Attachment: Minimal.zip
    (Size: 503.27KB, Downloaded 78 times)
Re: [EGL] Error when adding Enumeration Classes to the Model [message #1015761 is a reply to message #1015632] Sat, 02 March 2013 12:27 Go to previous message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 887
Registered: July 2009
Senior Member
Hi Patricia,

Thanks! Apparently, there seems to be a difference between the way the UML editor loads this model and the way Epsilon does but I haven't been able to spot it so far. Could you please file a bug report for this [1]? To speed things up it'd be great if you could try to load this model using the UML/EMF API from Java and let us know how if you find anything interesting.

Cheers,
Dimitris

[1] https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EMFT.Epsilon
Previous Topic:[EVL] Validate UML Model from Papyrus
Next Topic:Converting OCL constraints on EVL constraints
Goto Forum:
  


Current Time: Fri Oct 31 14:12:55 GMT 2014

Powered by FUDForum. Page generated in 0.01816 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software