Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » issue need your urgent attention regarding EVL constraints
issue need your urgent attention regarding EVL constraints [message #1014737] Tue, 26 February 2013 11:17 Go to next message
saad bin abid is currently offline saad bin abidFriend
Messages: 60
Registered: October 2009
Location: Ireland
Dear Epsilon Community members,
I need some urgent help from you regarding applying the EVL constraints on the metamodel I have prepared. I have three inter connected
> meta-models 1) featuremodel, 2) implementationmodel and 3)runtimerequiredactivation. all three models are under one DSL called
I am trying to compare the featuremodel attributes with
runtimerequiredactivation attributes. I am unable to do so. I uploaded the following files 1) DEMODSL.emf file from which you can generate the DSL
metamodel, editors etc, 2)demo.DemoDsl which is one instance of the DEMODSL
and RTA-PatternAnalysis.evl.

Please generate the code,editors and tests in the development environment.
After applying the evl constraints on the demo.DemoDsl instance i am
getting the following error

Property 'sources' not found in object

Many thanks,
Re: issue need your urgent attention regarding EVL constraints [message #1014958 is a reply to message #1014737] Tue, 26 February 2013 23:11 Go to previous message
Dimitris Kolovos is currently offline Dimitris KolovosFriend
Messages: 1067
Registered: July 2009
Senior Member
Hi Saad,

I've noticed that your metamodel makes use of nested packages - which are a common source of grief (see [1]). Could you please try to flatten your metamodel or split it across different files with 1 top EPackage each and see if this fixes the problem?


Previous Topic:[EGL] Expected to return a Set, but returned a class
Next Topic:Cannot integrate evl with emf tree-editor
Goto Forum:

Current Time: Tue Dec 01 03:54:58 GMT 2015

Powered by FUDForum. Page generated in 0.01685 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software