Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Migration to 3.0 - birt-charts problem
icon14.gif  Migration to 3.0 - birt-charts problem [message #1014735] Tue, 26 February 2013 11:11 Go to next message
k z is currently offline k z
Messages: 71
Registered: October 2012
Member
Hi,
Problem with Hudson BIRT Charts Plugin after migration to from Hudson 2.2.0 to Hudson 3.0.0. Indeed /home/tomcat6/.hudson/plugins/birt-charts folder is empty when META-INF is expected in it. Hudson Plugin Manager shows Hudson BIRT Charts Plugin is installed successfully

Feb 26, 2013 10:13:17 AM hudson.model.Hudson$5 onTaskFailed
SEVERE: Failed Inspecting plugin /home/tomcat6/.hudson/plugins/birt-charts.hpi
hudson.util.IOException2: Plugin installation failed. No manifest at /home/tomcat6/.hudson/plugins/birt-charts/META-INF/MANIFEST.MF
	at org.hudsonci.inject.internal.plugin.SmoothiePluginStrategy.createPluginWrapper(SmoothiePluginStrategy.java:98)
	at org.hudsonci.inject.internal.plugin.DelegatingPluginStrategy.createPluginWrapper(DelegatingPluginStrategy.java:62)
	at hudson.PluginManager$1$3$1.run(PluginManager.java:194)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
	at hudson.model.Hudson$4.runTask(Hudson.java:647)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Caused by: java.io.IOException: Plugin installation failed. No manifest at /home/tomcat6/.hudson/plugins/birt-charts/META-INF/MANIFEST.MF
	at hudson.ClassicPluginStrategy.createPluginWrapper(ClassicPluginStrategy.java:109)
	at org.hudsonci.inject.internal.plugin.PluginWrapperFactory.create(PluginWrapperFactory.java:86)
	at org.hudsonci.inject.internal.plugin.SmoothiePluginStrategy.createPluginWrapper(SmoothiePluginStrategy.java:95)
	... 10 more

[Updated on: Wed, 27 February 2013 14:46]

Report message to a moderator

Re: Migration to 3.0 - birt-charts problem [message #1015134 is a reply to message #1014735] Wed, 27 February 2013 14:45 Go to previous message
k z is currently offline k z
Messages: 71
Registered: October 2012
Member
Valid workaround:
When I manually extracted content of the hpi package and put it into the expected folder, the plugin was successfully loaded by hudson.
Previous Topic:Hudson version compatible with Java 1.7
Next Topic:Migration to 3.0 - copyArtifacts problem
Goto Forum:
  


Current Time: Tue Oct 21 04:05:49 GMT 2014

Powered by FUDForum. Page generated in 0.19851 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software