Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » EGit could not detect where Git is installed
EGit could not detect where Git is installed [message #1013824] Sun, 24 February 2013 12:13 Go to next message
Joe Shelley is currently offline Joe ShelleyFriend
Messages: 2
Registered: February 2013
Junior Member
Hi guys I have this problem, I have installed Eclipse (did have it in the past but never came across this error before when opening the same workspace)
The error is as follows:


"EGit does not require Git to function, but there may be important settings in the installation directory that EGit needs to know about in order to be compatible with Git. The most important of these settings is core.autocrlf. Git for Windows by default sets this parameter to true in the etc directory of the Git installation.
The directory can be configured in Preferences under Team > Git."


I then whenever I click OK get the following message:

"The environment variable HOME is not set. The following directory will be used for storing the GIT user configuration and as a default repository location: C:\Users|Pendrive. If this is not correct please set the HOME environment variable and restart Eclipse."


I'm not sure if the 2nd part of that helps or whether it is completely irrelevant to the first issue, all I know is any help would be greatly appreciated,

Thankyou for your time.
Re: EGit could not detect where Git is installed [message #1014106 is a reply to message #1013824] Mon, 25 February 2013 07:09 Go to previous message
Joffrey Chambrin is currently offline Joffrey ChambrinFriend
Messages: 7
Registered: January 2013
Junior Member
I think all you need to know is here : http://www.eclipse.org/forums/index.php/mv/msg/392682/932796/
Previous Topic:Team menu impoverished
Next Topic:Cannot get remote repository refs
Goto Forum:
  


Current Time: Sat Dec 20 05:57:25 GMT 2014

Powered by FUDForum. Page generated in 0.01658 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software