Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » "Debug all not pages" option not visible/working
"Debug all not pages" option not visible/working [message #1013268] Sat, 23 February 2013 06:50
hiro ali is currently offline hiro aliFriend
Messages: 2
Registered: February 2013
Junior Member
I've been trying to get Eclipse PDT (the latest all in one build w/ Indigo) to work with xdebug. Breakpoints are working fine, but only on the first page I specify on the debug configuration.

I've been trying to debug pages with get/post paramters and I've been reading all throughout the web there should be a "debug all pages" option which allows you to debug all pages on your local webserver (which would allow me to debug pages with get/post parameters easily). However, the option is not visible in the debug configuration -> Advanced Tab!

I noticed that the option does appear if you select ZEND debugger, but will not show if you select xdebug. Is there any particular reason why this option is not showing up for xdebug?

I even manually edited the .launch file in .metadata\.plugins\org.eclipse.debug.core\.launches to enable "debugallpages" as a workaround mentioned on stackoverflow, but it simply will not work.

Any advice would be appreciated.
Thanks!








Previous Topic:How to add PHP servers and debug configurations from outside?
Next Topic:"Debug all pages" option not showing.
Goto Forum:
  


Current Time: Mon Dec 22 09:58:36 GMT 2014

Powered by FUDForum. Page generated in 0.02375 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software